aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-httpauth
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 13:51:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 13:55:42 -0300
commitdb543be83894bc92d3d6a9b1a195c5606b072de9 (patch)
tree9b69440dd58b51d2e316c8e00697cf0de0e56732 /testing/py3-flask-httpauth
parentd2f36f0b69bf09dfbef7c666051b1afe0ed5b94a (diff)
downloadaports-db543be83894bc92d3d6a9b1a195c5606b072de9.tar.bz2
aports-db543be83894bc92d3d6a9b1a195c5606b072de9.tar.xz
testing/py3-flask-httpauth: rename from py-flask-httpauth
Diffstat (limited to 'testing/py3-flask-httpauth')
-rw-r--r--testing/py3-flask-httpauth/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-flask-httpauth/APKBUILD b/testing/py3-flask-httpauth/APKBUILD
new file mode 100644
index 0000000000..02f9f941c3
--- /dev/null
+++ b/testing/py3-flask-httpauth/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-httpauth
+_pkgname=Flask-HTTPAuth
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Basic and Digest HTTP authentication for Flask routes"
+url="https://pypi.python.org/pypi/Flask-HTTPAuth"
+arch="noarch"
+license="MIT"
+depends="python2 py-flask"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="710c47218b0b0ede9b333698fb559e7a Flask-HTTPAuth-2.1.0.tar.gz"
+sha256sums="cc7811f7ffcd31e84c561a402c0caa96ff49d28067a93036dc534d9f8b14ce2d Flask-HTTPAuth-2.1.0.tar.gz"
+sha512sums="0fef80572d42f31f39fb98083cbc0dc4dbde5999b5024262acda23aa60a96c767c528e4c379342f4c74303abee9c3843321b14c7a4abcba8e818b96718cc72bc Flask-HTTPAuth-2.1.0.tar.gz"