aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-peewee
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-02 22:02:52 +0300
committerprspkt <prspkt@protonmail.com>2019-06-02 22:46:38 +0300
commitb2be4a5a577d9cd16298cfa8c30919397b1bf974 (patch)
tree034091608588d323e3c05cc85ceaa337aea23dd9 /testing/py3-flask-peewee
parentb96e698aeec9c6e2ab92643a9d38e8cabb9ce545 (diff)
downloadaports-b2be4a5a577d9cd16298cfa8c30919397b1bf974.tar.bz2
aports-b2be4a5a577d9cd16298cfa8c30919397b1bf974.tar.xz
testing/py-flask-peewee: rename to py3-flask-peewee
Diffstat (limited to 'testing/py3-flask-peewee')
-rw-r--r--testing/py3-flask-peewee/APKBUILD30
1 files changed, 30 insertions, 0 deletions
diff --git a/testing/py3-flask-peewee/APKBUILD b/testing/py3-flask-peewee/APKBUILD
new file mode 100644
index 0000000000..97786ab7e4
--- /dev/null
+++ b/testing/py3-flask-peewee/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-flask-peewee
+_pkgname=flask-peewee
+pkgver=3.0.0
+pkgrel=2
+pkgdesc="Flask integration for peewee"
+url="http://pypi.python.org/pypi/flask-peewee"
+arch="noarch"
+license="MIT"
+depends="python3 py3-flask py-peewee py3-werkzeug py3-jinja2 py3-wtforms py-wtf-peewee"
+depends_dev=""
+makedepends="python3-dev py3-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e9773a46e73eb03864487d98da1c1f094a13807c2364331cdfad56878e2d8424628d04769e8028516ba62577c4a9c32219d2dffeabb87e88ae37baaff22f5bc9 flask-peewee-3.0.0.tar.gz"