aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-flask-principal/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 13:41:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 13:54:52 -0300
commit81825a1ac9714de3f28f1f09dcbaf408f2875bbe (patch)
tree33b2c8530f30e6d6df18bb0d43072fe07679c5ed /testing/py3-flask-principal/APKBUILD
parent8053a8f84cd066d748bafb29c49809ec483f1bea (diff)
downloadaports-81825a1ac9714de3f28f1f09dcbaf408f2875bbe.tar.bz2
aports-81825a1ac9714de3f28f1f09dcbaf408f2875bbe.tar.xz
testing/py3-flask-principal: rename from py-flask-principal
Diffstat (limited to 'testing/py3-flask-principal/APKBUILD')
-rw-r--r--testing/py3-flask-principal/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-flask-principal/APKBUILD b/testing/py3-flask-principal/APKBUILD
new file mode 100644
index 0000000000..b1f9a34699
--- /dev/null
+++ b/testing/py3-flask-principal/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-flask-principal
+_pkgname=Flask-Principal
+pkgver=0.4.0
+pkgrel=0
+pkgdesc="Flask Identity management"
+url="https://pypi.python.org/pypi/Flask-Principal"
+arch="noarch"
+license="BSD"
+depends="python2 py-flask"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="462d1345c9ddaddbec33a743e5821e2c Flask-Principal-0.4.0.tar.gz"
+sha256sums="f5d6134b5caebfdbb86f32d56d18ee44b080876a27269560a96ea35f75c99453 Flask-Principal-0.4.0.tar.gz"
+sha512sums="18f8f7766af62f99ccd52e34919e3f161ffb727c227c2714d651fad9bf6df3958289389e9b9cfe22d01a150985d1a631db3222626be1c4b12daea22434e4c85e Flask-Principal-0.4.0.tar.gz"