aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-fontmath
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-01-04 17:40:18 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-04 18:09:47 +0100
commit0fff0dd95912baca58e73a8f245ef8a7c15f8ec7 (patch)
treee9acda5b54b6ec6d97c150eb57332ddb90c6747b /testing/py3-fontmath
parent98d3eb078c32e2d834925599db6cd1a06e9e942d (diff)
downloadaports-0fff0dd95912baca58e73a8f245ef8a7c15f8ec7.tar.bz2
aports-0fff0dd95912baca58e73a8f245ef8a7c15f8ec7.tar.xz
testing/py3-fontmath: new aport
https://github.com/robotools/fontMath A set of objects for performing math operations on font data
Diffstat (limited to 'testing/py3-fontmath')
-rw-r--r--testing/py3-fontmath/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-fontmath/APKBUILD b/testing/py3-fontmath/APKBUILD
new file mode 100644
index 0000000000..31252198bf
--- /dev/null
+++ b/testing/py3-fontmath/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=py3-fontmath
+pkgver=0.5.2
+pkgrel=0
+pkgdesc="A set of objects for performing math operations on font data"
+url="https://github.com/robotools/fontMath"
+arch="noarch"
+license="MIT"
+depends="py3-fonttools python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+options="!check" # https://github.com/robotools/fontMath/issues/178
+source="https://files.pythonhosted.org/packages/source/f/fontMath/fontMath-$pkgver.zip"
+builddir="$srcdir/fontMath-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="c4f2f5c8a994b3ae3339e648e13f36f38fd075d01c5955ab896f73cdd29791e88c018c3f35590428c0756e301784b566fee1e71e19a65921ea27584b826e0327 fontMath-0.5.2.zip"