aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-glob2
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-05-07 22:08:33 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-05-07 22:11:41 +0200
commit01f4e3a31f2131fd88f1c6b4c795791869a4349a (patch)
tree59dabcc785567bd8da4be21747b5007c53ce9cde /testing/py3-glob2
parent21ab02bf01846bf852fa1e7d4080549e29aa981d (diff)
downloadaports-01f4e3a31f2131fd88f1c6b4c795791869a4349a.tar.bz2
aports-01f4e3a31f2131fd88f1c6b4c795791869a4349a.tar.xz
testing/py3-glob2: new aport
Diffstat (limited to 'testing/py3-glob2')
-rw-r--r--testing/py3-glob2/APKBUILD28
-rw-r--r--testing/py3-glob2/disable-failing-test.patch10
-rw-r--r--testing/py3-glob2/dont-package-tests.patch10
3 files changed, 48 insertions, 0 deletions
diff --git a/testing/py3-glob2/APKBUILD b/testing/py3-glob2/APKBUILD
new file mode 100644
index 0000000000..4ce5b53f6e
--- /dev/null
+++ b/testing/py3-glob2/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=py3-glob2
+_pkgname=glob2
+pkgver=0.6
+pkgrel=0
+pkgdesc="Version of the glob module that supports recursion via **, and can capture patterns"
+url="https://github.com/miracle2k/python-glob2"
+arch="noarch"
+license="BSD-2-Clause"
+depends="python3"
+checkdepends="py3-pytest"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest-3 test.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f4f17eb44d03c0675bc4e8832f2c7dbf42f37456bb664ebbc534d1ac0940061907aaf94b9d9d297dc79b2edfc0677912fdb1b4b47a1a6dfba7cf098135c5e839 glob2-0.6.tar.gz"
diff --git a/testing/py3-glob2/disable-failing-test.patch b/testing/py3-glob2/disable-failing-test.patch
new file mode 100644
index 0000000000..eeb41f20e0
--- /dev/null
+++ b/testing/py3-glob2/disable-failing-test.patch
@@ -0,0 +1,10 @@
+--- a/pkginfo/tests/test_installed.py.orig
++++ b/pkginfo/tests/test_installed.py
+@@ -44,6 +44,7 @@
+ else:
+ self.assertEqual(installed.metadata_version, '1.0')
+
++ @unittest.skip("FIXME: This test fails for unknown reason")
+ def test_ctor_w_package_no_PKG_INFO(self):
+ import sys
+ import types
diff --git a/testing/py3-glob2/dont-package-tests.patch b/testing/py3-glob2/dont-package-tests.patch
new file mode 100644
index 0000000000..045e0121a8
--- /dev/null
+++ b/testing/py3-glob2/dont-package-tests.patch
@@ -0,0 +1,10 @@
+--- a/setup.py
++++ b/setup.py
+@@ -48,6 +48,6 @@
+ 'pkginfo = pkginfo.commandline:main',
+ ]
+ },
+- packages=['pkginfo', 'pkginfo.tests'],
++ packages=['pkginfo'],
+ **extras
+ )