aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-grpcio
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2019-05-13 11:19:48 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-14 16:02:20 +0000
commit7561ae0971c13164a2fd357cf70180b4b15b1721 (patch)
tree4195bc470876c44da57a22757ed68add4baeceac /testing/py3-grpcio
parent5d4b28f96725dd477699826e07dd9fb6afc7dca7 (diff)
downloadaports-7561ae0971c13164a2fd357cf70180b4b15b1721.tar.bz2
aports-7561ae0971c13164a2fd357cf70180b4b15b1721.tar.xz
testing/py3-grpcio: new aport
Closes GH-7863
Diffstat (limited to 'testing/py3-grpcio')
-rw-r--r--testing/py3-grpcio/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/py3-grpcio/APKBUILD b/testing/py3-grpcio/APKBUILD
new file mode 100644
index 0000000000..6f82f92ec8
--- /dev/null
+++ b/testing/py3-grpcio/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Keith Maxwell <keith.maxwell@gmail.com>
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
+pkgname=py3-grpcio
+pkgver=1.20.0
+pkgrel=0
+pkgdesc="gRPC Python HTTP/2-based RPC framework"
+url="https://grpc.io"
+arch="all"
+license="Apache-2.0"
+makedepends="python3-dev py3-setuptools py3-six cython3 zlib-dev openssl-dev
+ c-ares-dev"
+options="!check" # tests depend upon bazel
+source="grpc-$pkgver.tar.gz::https://github.com/grpc/grpc/archive/v$pkgver.tar.gz"
+
+builddir="$srcdir/grpc-$pkgver"
+
+_set_environment_variables() {
+ export GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY=1
+ export GRPC_PYTHON_BUILD_SYSTEM_CARES=1
+ export GRPC_PYTHON_BUILD_SYSTEM_OPENSSL=1
+ export GRPC_PYTHON_BUILD_SYSTEM_ZLIB=1
+ export GRPC_PYTHON_BUILD_CYTHON=1
+}
+
+build() {
+ _set_environment_variables
+ python3 setup.py build
+}
+
+package() {
+ _set_environment_variables
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="01074f87a3cfaa30cbd3ae8f723118fd91cab586872b26b0f96fe5f8472dff8f6e8845af605765f747cc10ef1b62c974c57e08affc43eb8487b524a98d1dcae1 grpc-1.20.0.tar.gz"