aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-h2
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 02:28:13 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 11:19:25 -0300
commit66b2a7e54f6a9b7f45afa194696b338de3b6f171 (patch)
tree41894a0eb3ca77d60efb813d1bed1d3010d27f69 /testing/py3-h2
parent43c6c64b560da38ef0d939c5eb2c039a698d3221 (diff)
downloadaports-66b2a7e54f6a9b7f45afa194696b338de3b6f171.tar.bz2
aports-66b2a7e54f6a9b7f45afa194696b338de3b6f171.tar.xz
testing/py3-h2: rename from py-h2
Diffstat (limited to 'testing/py3-h2')
-rw-r--r--testing/py3-h2/APKBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/testing/py3-h2/APKBUILD b/testing/py3-h2/APKBUILD
new file mode 100644
index 0000000000..360dea6d8f
--- /dev/null
+++ b/testing/py3-h2/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: André Klitzing <aklitzing@gmail.com>
+# Maintainer: André Klitzing <aklitzing@gmail.com>
+pkgname=py-h2
+_pkgname=hyper-h2
+pkgver=3.0.0
+pkgrel=1
+pkgdesc="HTTP/2 State-Machine based protocol implementation"
+url="https://python-hyper.org/h2/"
+arch="noarch"
+license="MIT"
+makedepends="python2-dev py-setuptools python3-dev"
+subpackages="py3-${pkgname#py-}:_py3 py2-${pkgname#py-}:_py2"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python-hyper/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python3 setup.py build || return 1
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py() {
+ local python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+_py2() {
+ replaces="$pkgname"
+ _py python2
+}
+
+_py3() {
+ _py python3
+}
+
+sha512sums="33fbc08d28b347ed5be6257ea8ba45b59642951e6c716a27bdae86c1c5ccc388dd9bc5beaa62f6f59326f0fa0c39176bb4c8d7ab1c9ae3e2c056000ac2c3f75a py-h2-3.0.0.tar.gz"