aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hijri-converter/APKBUILD
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-07 16:01:07 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-09 20:05:22 +0000
commitf39ed6fc8ec381bf217ab83cbc24a72260bbe75f (patch)
tree4a5aea329f329875b482ccc3a3059bbb6829adfe /testing/py3-hijri-converter/APKBUILD
parentfd463f2e5c9e204c6afa4a1f4d9accee976c3513 (diff)
downloadaports-f39ed6fc8ec381bf217ab83cbc24a72260bbe75f.tar.bz2
aports-f39ed6fc8ec381bf217ab83cbc24a72260bbe75f.tar.xz
testing/py3-hijri-converter: new aport
Diffstat (limited to 'testing/py3-hijri-converter/APKBUILD')
-rw-r--r--testing/py3-hijri-converter/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-hijri-converter/APKBUILD b/testing/py3-hijri-converter/APKBUILD
new file mode 100644
index 0000000000..a72ce0a388
--- /dev/null
+++ b/testing/py3-hijri-converter/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Bart Ribberse <bribbers@disroot.org>
+# Maintainer: Bart Ribberse <bribbers@disroot.org>
+pkgname=py3-hijri-converter
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="Accurate Hijri-Gregorian date converter based on the Umm al-Qura calendar"
+url="https://github.com/dralshehri/hijri-converter"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+source="https://github.com/dralshehri/hijri-converter/archive/v$pkgver/hijri-converter-v$pkgver.tar.gz"
+builddir="$srcdir/hijri-converter-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ced1ad7ac6e552ef59bad3bea5a5f83b81d2b18138f9f5ebb1b5b2a54ab3a3eaf6827c32c7ffe97eed455b927315b093c8c78b6a8ec08bbfda4a6f5fee7b530b hijri-converter-v2.1.0.tar.gz"