aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-inotify/force-c-ext.patch
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-23 15:42:00 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-23 15:47:56 -0300
commite65b518f1be7d3b1555525028341223cacf0c9be (patch)
treeea9ed6c0ce2d05b92d6cda7a2176379828ba38a8 /testing/py3-inotify/force-c-ext.patch
parentd2d162df7081db100dfa5bf67c31257d6aafe9d4 (diff)
downloadaports-e65b518f1be7d3b1555525028341223cacf0c9be.tar.bz2
aports-e65b518f1be7d3b1555525028341223cacf0c9be.tar.xz
testing/py3-inotify: rebuild for py3-inotify
Diffstat (limited to 'testing/py3-inotify/force-c-ext.patch')
-rw-r--r--testing/py3-inotify/force-c-ext.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/testing/py3-inotify/force-c-ext.patch b/testing/py3-inotify/force-c-ext.patch
new file mode 100644
index 0000000000..4c86ca7535
--- /dev/null
+++ b/testing/py3-inotify/force-c-ext.patch
@@ -0,0 +1,14 @@
+diff --git a/setup.py b/setup.py
+index 15d68ab..5f6d7a6 100755
+--- a/setup.py
++++ b/setup.py
+@@ -3,7 +3,7 @@
+ # Set True to force compile native C-coded extension providing direct access
+ # to inotify's syscalls. If set to False this extension will only be compiled
+ # if no inotify interface from ctypes is found.
+-compile_ext_mod = False
++compile_ext_mod = True
+
+ # import statements
+ import os
+