aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-jmespath/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-01 16:57:52 +0300
committerprspkt <prspkt@protonmail.com>2019-07-01 16:58:03 +0300
commit6c4be714cd87fce186735179a11065e98af74ac4 (patch)
tree3b18cc5c23045f9b3a25b57134ac01b0eb13f24c /testing/py3-jmespath/APKBUILD
parent3cd0e54f386ace5c92f69da4851cade052f0c695 (diff)
downloadaports-6c4be714cd87fce186735179a11065e98af74ac4.tar.bz2
aports-6c4be714cd87fce186735179a11065e98af74ac4.tar.xz
testing/py3-jmespath: modernize
Diffstat (limited to 'testing/py3-jmespath/APKBUILD')
-rw-r--r--testing/py3-jmespath/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/testing/py3-jmespath/APKBUILD b/testing/py3-jmespath/APKBUILD
index 588f77ab89..e914591750 100644
--- a/testing/py3-jmespath/APKBUILD
+++ b/testing/py3-jmespath/APKBUILD
@@ -1,29 +1,27 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
# Contributor: Valery Kartel <valery.kartel@gmail.com>
pkgname=py3-jmespath
+_pkgname=jmespath
pkgver=0.9.3
pkgrel=1
-_pkgreal=${pkgname#py3-}
pkgdesc="JMESPath is a query language for JSON"
-url="http://jmespath.org"
+url="https://jmespath.org"
arch="noarch"
license="MIT"
options="!check"
depends="python3"
makedepends="py3-setuptools"
-source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgreal-$pkgver"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
replaces=py-jmespath # Backwards compatibility
provides=py-jmespath=$pkgver-r$pkgrel # Backwards compatibility
build() {
- cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}