aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-k5test
diff options
context:
space:
mode:
authorDmitry Romanenko <Dmitry@Romanenko.in>2019-06-06 20:16:26 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-06-09 07:33:58 -0300
commit0ad7b115617c2d8e0b07261ffec3c1cc2e5566ba (patch)
tree71fa0bf2bb4dfa315d6637448bd284dfa343f8e9 /testing/py3-k5test
parent3e4864e9ed5c266b5fb748205a4a71eb57cf5d0c (diff)
downloadaports-0ad7b115617c2d8e0b07261ffec3c1cc2e5566ba.tar.bz2
aports-0ad7b115617c2d8e0b07261ffec3c1cc2e5566ba.tar.xz
testing/py3-k5test: new aport
Diffstat (limited to 'testing/py3-k5test')
-rw-r--r--testing/py3-k5test/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-k5test/APKBUILD b/testing/py3-k5test/APKBUILD
new file mode 100644
index 0000000000..5df48cede0
--- /dev/null
+++ b/testing/py3-k5test/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Dmitry Romanenko <dmitry@romanenko.in>
+# Maintainer: Dmitry Romanenko <dmitry@romanenko.in>
+pkgname=py3-k5test
+_pkgname=k5test
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="A library for testing Python applications in self-contained Kerberos 5 environments"
+url="https://github.com/pythongssapi/k5test"
+arch="noarch"
+license="MIT"
+depends="python3 py-six krb5-dev"
+options="!check" # Package doesn't have tests
+source="https://files.pythonhosted.org/packages/source/k/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="fa32d5baf36cf76dd8cef09b7bb8d5c7ce363f80a4112aaf76b2196c7e1c3b8318d8f7f1fa5a1968f670611ea331366c7cae948c1695a2de9c0fbc25248eab16 k5test-0.9.2.tar.gz"