aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-librtmp
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-31 04:50:17 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-31 14:01:12 -0300
commit40f46a1a632b3984ed3a2332984b71eb8fab9b18 (patch)
treec515d1288d8d204f1b8bae35045587dd0593f97b /testing/py3-librtmp
parentd29fc5c4c150508d8567cd6cfe799a4faa4f097b (diff)
downloadaports-40f46a1a632b3984ed3a2332984b71eb8fab9b18.tar.bz2
aports-40f46a1a632b3984ed3a2332984b71eb8fab9b18.tar.xz
testing/py3-librtmp: rename from py-librtmp
Diffstat (limited to 'testing/py3-librtmp')
-rw-r--r--testing/py3-librtmp/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-librtmp/APKBUILD b/testing/py3-librtmp/APKBUILD
new file mode 100644
index 0000000000..39a08018fc
--- /dev/null
+++ b/testing/py3-librtmp/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py-librtmp
+_pkgname=python-librtmp
+pkgver=0.3.0
+pkgrel=0
+pkgdesc="Python bindings for librtmp, built with cffi"
+url="https://pypi.python.org/pypi/python-librtmp"
+arch="all"
+license="BSD"
+depends="py-setuptools rtmpdump-dev py-cffi py2-singledispatch "
+depends_dev=""
+makedepends="$depends_dev python2-dev"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir"/$_pkgname-$pkgver
+build() {
+ cd "$builddir"
+ python2 setup.py build || return 1
+ python2 setup.py test || return 1
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="f7afe8d463214072281998fa84553927 python-librtmp-0.3.0.tar.gz"
+sha256sums="4a41ada646270baa5b388f17481d08679d23b2947835901d0db7602c59ec772b python-librtmp-0.3.0.tar.gz"
+sha512sums="1fa529f5c68341f225849061cbcf6883f80e48a492fae8319336ea1e17c22070d5bd204f768b2561b0ef8dfdf29b38789673fab3d3386290143eb94d2b51b8fe python-librtmp-0.3.0.tar.gz"