aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-nbxmpp
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-21 23:03:36 +0300
committerprspkt <prspkt@protonmail.com>2019-07-21 23:04:36 +0300
commitc41716b0eba2b83b0152311b8a29b173a42dd6ea (patch)
tree8249df3ec29e20dfe81ec2ed49c268caf2203705 /testing/py3-nbxmpp
parenta5925a4322729e766d2bc91ee3fd593a9f07885f (diff)
downloadaports-c41716b0eba2b83b0152311b8a29b173a42dd6ea.tar.bz2
aports-c41716b0eba2b83b0152311b8a29b173a42dd6ea.tar.xz
testing/py-nbxmpp: drop python2
Diffstat (limited to 'testing/py3-nbxmpp')
-rw-r--r--testing/py3-nbxmpp/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-nbxmpp/APKBUILD b/testing/py3-nbxmpp/APKBUILD
new file mode 100644
index 0000000000..8308897863
--- /dev/null
+++ b/testing/py3-nbxmpp/APKBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
+pkgname=py3-nbxmpp
+_pkgname=nbxmpp
+pkgver=0.6.10
+pkgrel=1
+pkgdesc="A non-blocking XMPP implementation for python"
+url="https://dev.gajim.org/gajim/python-nbxmpp/"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+options="!check" # no test suite
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-nbxmpp # Backwards compatibility
+provides=py-nbxmpp=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="df586498ea66da4b6720753b25bd0222ee3360684e844d0d5bc2f364c2566243cc358976fe34b050e3358c3e584f880d8ac1c34e84eca34efaa18ab0c2f37eaf nbxmpp-0.6.10.tar.gz"