aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-ncclient
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-22 00:11:34 +0300
committerprspkt <prspkt@protonmail.com>2019-06-22 00:19:10 +0300
commit99de1a9fac9c1b42e091b116b20098e715eddb6e (patch)
treef191328f2ca73216d36cfb4a293a6773570ac17f /testing/py3-ncclient
parentecc71baf4ed19f9bcb7c7bf0ad2a66b7fd204b03 (diff)
downloadaports-99de1a9fac9c1b42e091b116b20098e715eddb6e.tar.bz2
aports-99de1a9fac9c1b42e091b116b20098e715eddb6e.tar.xz
testing/py3-ncclient: modernize, fix url
Diffstat (limited to 'testing/py3-ncclient')
-rw-r--r--testing/py3-ncclient/APKBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/testing/py3-ncclient/APKBUILD b/testing/py3-ncclient/APKBUILD
index 8ddad99983..4fe2b492b1 100644
--- a/testing/py3-ncclient/APKBUILD
+++ b/testing/py3-ncclient/APKBUILD
@@ -5,25 +5,23 @@ _pkgname=ncclient
pkgver=0.5.3
pkgrel=1
pkgdesc="Library for NETCONF clients"
-url="https://github.com/tomchristie/itypes"
+url="https://github.com/ncclient/ncclient"
arch="noarch"
license="Apache-2.0"
depends="py3-lxml py3-paramiko py3-setuptools py3-six"
options="!check" #no testsuite
-source="$pkgname-$pkgver.tar.gz::https://github.com/ncclient/ncclient/archive/v$pkgver.tar.gz"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/ncclient/ncclient/archive/v$pkgver.tar.gz"
builddir="$srcdir"/ncclient-$pkgver
replaces="py-ncclient" # Backwards compatibility
provides="py-ncclient=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$builddir"
- python3 setup.py --quiet build
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python3 setup.py --quiet install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="53320a745dda98cd6e7c2e4cf87df446b90b74982543e529810225060c5774a4c3f2470a3d6e4fd84ad83cac11a4ea50b538a9a95c5d9cfd5c5714c693342217 py-ncclient-0.5.3.tar.gz"