aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pem
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-02 05:57:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-02 05:59:25 -0300
commit2d4ee2ac804c190c8163e6d91e3d9997eeb0d6e3 (patch)
tree12d593bf57bea7f86b4a6fbf3ff35f005ada751f /testing/py3-pem
parent5ab90c5846150d2516674bd767788451e720a50a (diff)
downloadaports-2d4ee2ac804c190c8163e6d91e3d9997eeb0d6e3.tar.bz2
aports-2d4ee2ac804c190c8163e6d91e3d9997eeb0d6e3.tar.xz
testing/py3-pem: new aport
https://pem.readthedocs.io/en/stable/ Easy PEM file parsing
Diffstat (limited to 'testing/py3-pem')
-rw-r--r--testing/py3-pem/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-pem/APKBUILD b/testing/py3-pem/APKBUILD
new file mode 100644
index 0000000000..893939c68b
--- /dev/null
+++ b/testing/py3-pem/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-pem
+pkgver=19.1.0
+pkgrel=0
+pkgdesc="Easy PEM file parsing"
+options="!check" # Requires unpackaged pymodule 'pretend'
+url="https://pem.readthedocs.io/en/stable/"
+arch="all"
+license="MIT"
+depends="python3 py3-twisted"
+makedepends="py3-setuptools"
+checkdepends="py3-pytest py3-certifi py3-openssl"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hynek/pem/archive/$pkgver.tar.gz"
+builddir="$srcdir/pem-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="873c34f1bb4c40be179d40b175f3791d021ce0faf9c9578efe494dc60945d291f3ed35aee7e534b326671dd6d4990c3d0060a85178fbdadf423c83e3bde8e185 py3-pem-19.1.0.tar.gz"