aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-praw
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-09-16 06:38:35 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-09-16 07:29:02 +0000
commitafad2d8f1f0a3b3b6741390f062f67a4892ba097 (patch)
treebcbc9302715ebe8caae3bfb3387f1b7a10e0c7d9 /testing/py3-praw
parent6ac0abb933ac2e68aa28f8d766a26e0b17747272 (diff)
downloadaports-afad2d8f1f0a3b3b6741390f062f67a4892ba097.tar.bz2
aports-afad2d8f1f0a3b3b6741390f062f67a4892ba097.tar.xz
testing/py3-praw: upgrade to 6.3.1
Diffstat (limited to 'testing/py3-praw')
-rw-r--r--testing/py3-praw/APKBUILD12
-rw-r--r--testing/py3-praw/relax-version-requirements.patch18
2 files changed, 5 insertions, 25 deletions
diff --git a/testing/py3-praw/APKBUILD b/testing/py3-praw/APKBUILD
index 8b439f8c78..d8e2afca47 100644
--- a/testing/py3-praw/APKBUILD
+++ b/testing/py3-praw/APKBUILD
@@ -2,17 +2,16 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-praw
_pkgname=praw
-pkgver=4.0.0
-pkgrel=4
+pkgver=6.3.1
+pkgrel=0
pkgdesc="A Python module to access to reddit's API"
url="https://github.com/praw-dev/praw"
arch="noarch"
license="GPL-3.0-or-later"
-depends="py3-prawcore py3-update-checker py3-requests py3-six py3-decorator"
+depends="py3-prawcore py3-update-checker py3-requests py3-six py3-websocket-client"
makedepends="py3-setuptools"
checkdepends="pytest"
-source="$_pkgname-$pkgver.tar.gz::https://github.com/praw-dev/praw/archive/v$pkgver.tar.gz
- relax-version-requirements.patch"
+source="$_pkgname-$pkgver.tar.gz::https://github.com/praw-dev/praw/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
replaces="py-praw" # Backwards compatibility
@@ -30,5 +29,4 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="adf33b1e51cbbf1ed96ed57360ba25c9449e6649b6bd923d392c74814a2e296dec5b5bcae963dc8428dfb6d047a2eeaaf1fe6e902cfb9081b0875ab95e9dde6b praw-4.0.0.tar.gz
-d24fe8e817963fdc374d00faf2d18a2383b65feb8a06adc84b77663f43c123824caf03219546dcf3ebbb605e6f31e5f6963291b9aa632a6af8c8009ca38a5f75 relax-version-requirements.patch"
+sha512sums="0e2a007e8ded7def5ac293c83aa2b96c108dc98a484dd06c48f300feb4298a95cf14868576f921f5b8910448f424d92ada035dc635e79ce89e24170a47230839 praw-6.3.1.tar.gz"
diff --git a/testing/py3-praw/relax-version-requirements.patch b/testing/py3-praw/relax-version-requirements.patch
deleted file mode 100644
index 3bfac8917c..0000000000
--- a/testing/py3-praw/relax-version-requirements.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-diff --git a/setup.py b/setup.py.new
-index 2cc9975725..1f2e5dffba 100644
---- a/setup.py
-+++ b/setup.py.new
-@@ -36,10 +36,10 @@ setup(name=PACKAGE_NAME,
- description=('PRAW, an acronym for `Python Reddit API Wrapper`, is a '
- 'python package that allows for simple access to '
- 'reddit\'s API.'),
-- install_requires=['decorator >=4.0.9, <4.1',
-- 'prawcore >=0.3.0, <0.4',
-+ install_requires=['decorator >=4.0.9, <4.4',
-+ 'prawcore >=0.3.0',
- 'requests >=2.3.0',
-- 'six ==1.10',
-+ 'six >=1.10',
- 'update_checker >=0.12'],
- keywords='reddit api wrapper',
- license='Simplified BSD License',