aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pycountry
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-26 00:21:34 +0200
committerprspkt <prspkt@protonmail.com>2019-03-26 01:03:15 +0200
commit907b6fc004a5644141ddd65650cd068359310015 (patch)
treed569d3d97278099dd7235b5493d29ccb9bcbec73 /testing/py3-pycountry
parent3d33d6fe2349564c4476b6fef46eeeee6c470928 (diff)
downloadaports-907b6fc004a5644141ddd65650cd068359310015.tar.bz2
aports-907b6fc004a5644141ddd65650cd068359310015.tar.xz
testing/py-pycountry: upgrade to python3
- Add python3 depends. - Remove py-lxml makedepends due to upstream switching from XML to JSON formatted databases.
Diffstat (limited to 'testing/py3-pycountry')
-rw-r--r--testing/py3-pycountry/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pycountry/APKBUILD b/testing/py3-pycountry/APKBUILD
new file mode 100644
index 0000000000..393de4662c
--- /dev/null
+++ b/testing/py3-pycountry/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-pycountry
+_pkgname=pycountry
+pkgver=18.12.8
+pkgrel=0
+pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
+url="https://pypi.org/project/pycountry"
+arch="noarch"
+license="LGPL-2.1-or-later"
+provides="py-pycountry" # for backwards compatibility
+replaces="py-pycountry=$pkgver-r$pkgrel" # for backwards compatibility
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9797688ada8ea54c1a56a2cf4d0ad765001816c822c40077953fa71e3af285114c4b5beaf739a24432b9c6ea794952ce347a40ae0bcd9a2c00d12ddc7b45261e pycountry-18.12.8.tar.gz"