aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyisbn
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-07-21 23:15:09 +0300
committerprspkt <prspkt@protonmail.com>2019-07-21 23:23:07 +0300
commitc15b901aad3185b9c8dbf83d2824264032943da7 (patch)
tree9fc69e66da3eed3f2d4326d29522a8f0375d1cea /testing/py3-pyisbn
parentdbf74790c23d825ca58c326e594e85b8a8344a7b (diff)
downloadaports-c15b901aad3185b9c8dbf83d2824264032943da7.tar.bz2
aports-c15b901aad3185b9c8dbf83d2824264032943da7.tar.xz
testing/py-pyisbn: drop python2, modernize
Diffstat (limited to 'testing/py3-pyisbn')
-rw-r--r--testing/py3-pyisbn/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-pyisbn/APKBUILD b/testing/py3-pyisbn/APKBUILD
new file mode 100644
index 0000000000..aedb2b9889
--- /dev/null
+++ b/testing/py3-pyisbn/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-pyisbn
+_pkgname=pyisbn
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="A module for working with 10- and 13-digit ISBNs"
+url="https://github.com/JNRowe/pyisbn"
+arch="noarch"
+license="GPL-3.0-or-later"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+replaces=py-isbn # Backwards compatibility
+provides=py-isbn=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="9c54199d4a152b7e0ff32ba71b0479dbbbd426a3a1e5b7b08d8619cdae445e13562fd682c9f4c5857075b4c9b50731a715402d8c9463ad48046013c7defcbc28 pyisbn-1.1.0.tar.gz"