aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pymaging
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 11:45:28 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 11:48:37 -0300
commit6a32ecd5d8f99c75f449f822d7853f752feab9a5 (patch)
treef4d7e9b3e1d3968996b19bb26509541297a87c76 /testing/py3-pymaging
parentda8a05b05fa5ddbd3873f6e44710af6e56d9860f (diff)
downloadaports-6a32ecd5d8f99c75f449f822d7853f752feab9a5.tar.bz2
aports-6a32ecd5d8f99c75f449f822d7853f752feab9a5.tar.xz
testing/py3-pymaging: drop py2
Diffstat (limited to 'testing/py3-pymaging')
-rw-r--r--testing/py3-pymaging/APKBUILD49
1 files changed, 14 insertions, 35 deletions
diff --git a/testing/py3-pymaging/APKBUILD b/testing/py3-pymaging/APKBUILD
index 064dd43e3a..9fff5b6ff1 100644
--- a/testing/py3-pymaging/APKBUILD
+++ b/testing/py3-pymaging/APKBUILD
@@ -1,52 +1,31 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=py-pymaging
+pkgname=py3-pymaging
_pkgname=pymaging
_commit=596a08fce5664e58d6e8c96847393fbe987783f2
pkgver=0.0.20130908
-pkgrel=2
+pkgrel=3
pkgdesc="Pure Python imaging library"
-url="https://github.com/ojii/$_pkgname/"
+url="https://github.com/ojii/pymaging"
arch="noarch"
-license="BSD-3-Clause MIT custom"
-depends=
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+license="BSD-3-Clause AND MIT"
+depends="python3"
+makedepends="py3-setuptools"
source="$pkgname-$pkgver.tar.gz::https://github.com/ojii/$_pkgname/archive/$_commit.tar.gz"
builddir="$srcdir"/$_pkgname-$_commit
+replaces="py-pymaging" # Backwards compatibility
+provides="py-pymaging=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- _py python2
- rm -rf "$subpkgdir/usr/bin"
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
check() {
- cd "$builddir"
- python2 setup.py test
python3 setup.py test
}
-sha512sums="757431eb53ee839ae8f341c5021b96a704a78434bb81f843de36c0b8274ca8de603ca5f04bf6e38a5dae39d42be2da05f03119235fe5ca5d34bd10fa30faa813 py-pymaging-0.0.20130908.tar.gz"
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="757431eb53ee839ae8f341c5021b96a704a78434bb81f843de36c0b8274ca8de603ca5f04bf6e38a5dae39d42be2da05f03119235fe5ca5d34bd10fa30faa813 py3-pymaging-0.0.20130908.tar.gz"