aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid-addons
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:19:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:24:12 -0300
commitb9521d323d37672ccf6daabee20b7209eef39467 (patch)
treee5065ccf392b883c01255f9dd63d947940b7f8d7 /testing/py3-pyramid-addons
parent0760f34c46fb16a27614858d86a499b5cb142e07 (diff)
downloadaports-b9521d323d37672ccf6daabee20b7209eef39467.tar.bz2
aports-b9521d323d37672ccf6daabee20b7209eef39467.tar.xz
testing/py3-pyramid-addons: rename from py-pyramid-addons
Diffstat (limited to 'testing/py3-pyramid-addons')
-rw-r--r--testing/py3-pyramid-addons/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/py3-pyramid-addons/APKBUILD b/testing/py3-pyramid-addons/APKBUILD
new file mode 100644
index 0000000000..bff2c19d57
--- /dev/null
+++ b/testing/py3-pyramid-addons/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyramid-addons
+_pkgname=pyramid_addons
+pkgver=0.20
+pkgrel=0
+pkgdesc="A pyramid plugin that provides extra functionality"
+url="https://github.com/bboe/pyramid_addons"
+arch="noarch"
+license="BSD"
+depends="python2 py-pyramid"
+depends_dev=""
+makedepends="python2-dev py-setuptools"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python2 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="b83599edf4af7d0cff1521aa44a73578 pyramid_addons-0.20.tar.gz"
+sha256sums="e0816e541296cb59ddf8426db442c7042b2798e661f2dae316075269b2bbbf5e pyramid_addons-0.20.tar.gz"
+sha512sums="82916783fa13fb077fbc6bd76ee194dccff49dfaa1714d35ed6bad8062886851056326e6733d6e418528f957ab96e0b568caad16f9139386c0f5668e56fa41f4 pyramid_addons-0.20.tar.gz"