aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid-layout
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:25:37 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:37:14 -0300
commit07fb2532e79ac1d1bdaed5e855d6d4fe9a388c9b (patch)
tree82f6ccaee076e5494f5dd84eecdb3f65e39c08d7 /testing/py3-pyramid-layout
parent3d3b0f642d0408c9b24230e4721a35b703fb1e71 (diff)
downloadaports-07fb2532e79ac1d1bdaed5e855d6d4fe9a388c9b.tar.bz2
aports-07fb2532e79ac1d1bdaed5e855d6d4fe9a388c9b.tar.xz
testing/py3-pyramid-layout: rename from py-pyramid-layout
Diffstat (limited to 'testing/py3-pyramid-layout')
-rw-r--r--testing/py3-pyramid-layout/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pyramid-layout/APKBUILD b/testing/py3-pyramid-layout/APKBUILD
new file mode 100644
index 0000000000..6087effa55
--- /dev/null
+++ b/testing/py3-pyramid-layout/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py-pyramid-layout
+_pkgname=pyramid_layout
+pkgver=1.0
+pkgrel=0
+pkgdesc="A pyramid plugin that provides UI layout"
+url="https://pypi.python.org/pypi/pyramid_layout"
+arch="noarch"
+license="BSD"
+depends="python2 py-pyramid"
+makedepends="python2-dev py-setuptools"
+options="!check"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+}
+
+package() {
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3cabb35cc0bb7a09f8b5b2ef439e689e3ab484bf73bb2664f4d250624dca601eada7204d894956bbc194a1da1977ded6d8d26c566f56fbde3c219adbfd7379be pyramid_layout-1.0.tar.gz"