aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyroute2/APKBUILD
diff options
context:
space:
mode:
authorThomas Liske <thomas@fiasko-nw.net>2020-04-08 00:24:13 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-07 22:30:59 +0000
commit54f744cf121dddcf2113a8b07f9badd703987948 (patch)
treecf8636264f016c29b59a04224be1a2692b0da668 /testing/py3-pyroute2/APKBUILD
parent65a8bb5eb57d6f7e739f81e325c8c832736595b7 (diff)
downloadaports-54f744cf121dddcf2113a8b07f9badd703987948.tar.bz2
aports-54f744cf121dddcf2113a8b07f9badd703987948.tar.xz
testing/py3-pyroute2: add aport
Diffstat (limited to 'testing/py3-pyroute2/APKBUILD')
-rw-r--r--testing/py3-pyroute2/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-pyroute2/APKBUILD b/testing/py3-pyroute2/APKBUILD
new file mode 100644
index 0000000000..84f7bbfba1
--- /dev/null
+++ b/testing/py3-pyroute2/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thomas Liske <thomas@fiasko-nw.net>
+pkgname=py3-pyroute2
+_pkgname=pyroute2
+pkgver=0.5.11
+pkgrel=0
+pkgdesc="Python Netlink library"
+url="https://github.com/svinota/pyroute2"
+arch="noarch"
+license="GPL-2.0-or-later OR Apache-2.0"
+makedepends="py3-setuptools py3-pytest"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ pytest
+}
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ # do not ship cli scripts for now
+ rm -rf "${pkgdir:?}/usr/bin"
+}
+
+sha512sums="38159cb3467711a73742c75154828563681df79dedba040a49fadc11afda5bbae756f724d89905fb24c7ce0d4fa0a6107aac9750586286a15eeffaaa8fa3d6bc pyroute2-0.5.11.tar.gz"