aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pytest-black
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-05-07 16:20:33 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-05-09 20:05:23 +0000
commitc021c76304533d58ce867bc606d4e60228bc7790 (patch)
tree80fa26895ed6536c3ecec4af8c27348483d0d907 /testing/py3-pytest-black
parent09193f227405e862e910c8bb2e9a0bd0ec3462e2 (diff)
downloadaports-c021c76304533d58ce867bc606d4e60228bc7790.tar.bz2
aports-c021c76304533d58ce867bc606d4e60228bc7790.tar.xz
testing/py3-pytest-black: new aport
Diffstat (limited to 'testing/py3-pytest-black')
-rw-r--r--testing/py3-pytest-black/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-pytest-black/APKBUILD b/testing/py3-pytest-black/APKBUILD
new file mode 100644
index 0000000000..d695980444
--- /dev/null
+++ b/testing/py3-pytest-black/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Bart Ribberse <bribbers@disroot.org>
+# Maintainer: Bart Ribberse <bribbers@disroot.org>
+pkgname=py3-pytest-black
+pkgver=0.3.9
+pkgrel=0
+pkgdesc="A pytest plugin to enable format checking with black"
+url="https://github.com/shopkeep/pytest-black"
+arch="noarch !mips !mips64 !s390x" # Blocked by black
+license="MIT"
+depends="python3 py3-pytest black py3-toml"
+makedepends="py3-setuptools py3-setuptools_scm"
+source="https://pypi.python.org/packages/source/p/pytest-black/pytest-black-$pkgver.tar.gz"
+builddir="$srcdir/pytest-black-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ # Hack entry point by installing it
+ python3 setup.py install --root="$PWD/tmp_install"
+ PYTHONPATH="$PWD/tmp_install/usr/lib/python3.8/site-packages:$PYTHONPATH" pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="66e73927f7e0720b6f42b2798f6e4fd3697fe69892ca1d6402040ba5f9520bcfadff3d441b3799b013e35d150974e0cd9b4b433663802cc0b04520cb6c72b741 pytest-black-0.3.9.tar.gz"