aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pytest-flake8
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-06-30 14:24:30 -0400
committerLeo <thinkabit.ukim@gmail.com>2019-07-06 04:05:00 -0300
commit77f65435c248fefa51a454ff4505f5b1e1857457 (patch)
tree9fb0b6da70076d0cf4f0c6f83d049c678a43e8dc /testing/py3-pytest-flake8
parentc87c942f36466e2ef63dec554dc8948eab6cb8c3 (diff)
downloadaports-77f65435c248fefa51a454ff4505f5b1e1857457.tar.bz2
aports-77f65435c248fefa51a454ff4505f5b1e1857457.tar.xz
testing/py3-pytest-flake8: new APKBUILD
Diffstat (limited to 'testing/py3-pytest-flake8')
-rw-r--r--testing/py3-pytest-flake8/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-pytest-flake8/APKBUILD b/testing/py3-pytest-flake8/APKBUILD
new file mode 100644
index 0000000000..be843aeaf2
--- /dev/null
+++ b/testing/py3-pytest-flake8/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py3-pytest-flake8
+_pyname=pytest-flake8
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="pytest plugin for efficiently checking PEP8 compliance"
+url="https://pypi.org/project/pytest-flake8/"
+arch="noarch"
+license="3-Clause-BSD"
+depends="py3-pytest py3-flake8"
+makedepends="py3-setuptools"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="39ac19f3216386dc33b7c3c7c12a026751bb636d140340eb9585e161292d74f587c3a032125380bd12834e841172bf47652c19036bd06d493abd11cefe428429 pytest-flake8-1.0.4.tar.gz"