aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-serpent
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 10:23:42 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 13:25:54 -0300
commit9e57cadf8cfd1c5afe4b20df6f1c2feb89baa91d (patch)
tree04788f4c255a672fc8c20e6270c9ba017b82de47 /testing/py3-serpent
parent03f33cec0e73ab8f3406bb0c558d64ff4a2e3f0b (diff)
downloadaports-9e57cadf8cfd1c5afe4b20df6f1c2feb89baa91d.tar.bz2
aports-9e57cadf8cfd1c5afe4b20df6f1c2feb89baa91d.tar.xz
testing/py3-serpent: rename from py-serpent
Diffstat (limited to 'testing/py3-serpent')
-rw-r--r--testing/py3-serpent/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/testing/py3-serpent/APKBUILD b/testing/py3-serpent/APKBUILD
new file mode 100644
index 0000000000..067116558c
--- /dev/null
+++ b/testing/py3-serpent/APKBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-serpent
+_pyname=serpent
+pkgver=1.28
+pkgrel=1
+pkgdesc="Serialization based on ast.literal_eval for Python"
+url="https://pypi.org/project/serpent/"
+arch="noarch"
+license="MIT"
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="python2 python3 py2-setuptools py3-setuptools"
+checkdepends="py2-attrs py3-attrs py2-tz py3-tz"
+_pypiprefix="${_pyname%${_pyname#?}}"
+source="https://files.pythonhosted.org/packages/source/$_pypiprefix/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir=$srcdir/$_pyname-$pkgver
+
+prepare() {
+ cp -r "$builddir" "$builddir"-py2
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+ cd "$builddir"-py2
+ python2 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+ cd "$builddir"-py2
+ python2 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ cd "$builddir"-py2
+ _py python2
+}
+
+_py3() {
+ cd "$builddir"
+ _py python3
+}
+
+_py() {
+ _python="$1"
+ pkgdesc="$pkgdesc (for $_python)"
+ depends="$depends $_python"
+ install_if="$pkgname=$pkgver-r$pkgrel $_python"
+ $_python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="776bc497c7cd815c4ef44107bdf53b62bb92229beba0be7efceb9fba57dc7c677bf09832db335485df3e466acdffe6ebf4b3636ae9b49e60075379a7419a29ad serpent-1.28.tar.gz"