aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-sparqlwrapper
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2019-08-23 10:31:55 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-08-23 15:05:05 -0300
commitdf9a1c1f5cebd9cb8f6926b70142e9fa4f1debcb (patch)
tree5f3e5bf5401897b040e044dd0fe140b1ef4427e4 /testing/py3-sparqlwrapper
parent403e448946826ec7d9a44b68bc722daca726c784 (diff)
downloadaports-df9a1c1f5cebd9cb8f6926b70142e9fa4f1debcb.tar.bz2
aports-df9a1c1f5cebd9cb8f6926b70142e9fa4f1debcb.tar.xz
testing/py3-sparqlwrapper: new aport
Diffstat (limited to 'testing/py3-sparqlwrapper')
-rw-r--r--testing/py3-sparqlwrapper/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-sparqlwrapper/APKBUILD b/testing/py3-sparqlwrapper/APKBUILD
new file mode 100644
index 0000000000..b1f61ea10d
--- /dev/null
+++ b/testing/py3-sparqlwrapper/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Luca Weiss <luca@z3ntu.xyz>
+pkgname=py3-sparqlwrapper
+_pkgname=sparqlwrapper
+pkgver=1.8.4
+pkgrel=0
+pkgdesc="SPARQL Endpoint interface to Python"
+url="https://rdflib.github.io/sparqlwrapper/"
+arch="noarch"
+license="W3C"
+checkdepends="bash py3-nose"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/RDFLib/sparqlwrapper/archive/$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ # Tests soft-fail because of the missing rdflib-jsonld dependency.
+ # This dependency had its last release in 2016 and is apparently not
+ # compatible with Python 3.
+ # py3-rdflib should also be a dep but that would cause a circular
+ # dependency loop.
+ ./run_tests_py3.sh
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="b89fe07319a3108f29fe984c7ae7381c30db6f655da35c5d193b7365fde4dbbc4f7575defe0371aff6c5d6d626e36c15b6fa8685c1d12eb19ae73d3bd3650eac py3-sparqlwrapper-1.8.4.tar.gz"