aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-terminaltables/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-19 01:01:03 +0300
committerprspkt <prspkt@protonmail.com>2019-08-19 01:06:58 +0300
commitead59c4fea378eddb79a3b96415313fa70305a54 (patch)
tree2874ffe5576f3f5507a3651270d098b1c13cf444 /testing/py3-terminaltables/APKBUILD
parented65890150dc07644f7dfd4c6a5c3f19fabf0f3b (diff)
downloadaports-ead59c4fea378eddb79a3b96415313fa70305a54.tar.bz2
aports-ead59c4fea378eddb79a3b96415313fa70305a54.tar.xz
testing/py-terminaltables: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'testing/py3-terminaltables/APKBUILD')
-rw-r--r--testing/py3-terminaltables/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/py3-terminaltables/APKBUILD b/testing/py3-terminaltables/APKBUILD
new file mode 100644
index 0000000000..3be3cf48bc
--- /dev/null
+++ b/testing/py3-terminaltables/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Thomas Boerger <thomas@webhippie.de>
+# Maintainer: Thomas Boerger <thomas@webhippie.de>
+pkgname=py3-terminaltables
+_pkgname=terminaltables
+pkgver=3.1.0
+pkgrel=2
+pkgdesc="Generate simple tables in terminals from a nested list of strings"
+url="https://pypi.python.org/pypi/terminaltables"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces=py-terminaltables # Backwards compatibility
+provides=py-terminaltables=$pkgver-r$pkgrel # Backwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="f30620f57c4d40b4ee5736d2886e744f7ed34aae702252b2ecf90844d314c4ccce7a7bc9146637504e6996c148567ba16247136f081f086a2b264f2f4920ecd8 terminaltables-3.1.0.tar.gz"