aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-txacme
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-02 06:32:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-02 16:28:29 -0300
commit2f487d2f56d9b2b542cc9f99182efa0cc2803ff6 (patch)
tree6108dac7ea096fa386c1774eed8e2361f89f6ab0 /testing/py3-txacme
parent99e1beeb60e72fbb3c102adf864aa268d82ea2ba (diff)
downloadaports-2f487d2f56d9b2b542cc9f99182efa0cc2803ff6.tar.bz2
aports-2f487d2f56d9b2b542cc9f99182efa0cc2803ff6.tar.xz
testing/py3-txacme: new aport
https://github.com/mithrandi/txacme ACME protocol implementation for Twisted
Diffstat (limited to 'testing/py3-txacme')
-rw-r--r--testing/py3-txacme/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/py3-txacme/APKBUILD b/testing/py3-txacme/APKBUILD
new file mode 100644
index 0000000000..35b43fadd2
--- /dev/null
+++ b/testing/py3-txacme/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-txacme
+pkgver=0.9.2
+pkgrel=0
+pkgdesc="ACME protocol implementation for Twisted"
+options="!check" # Requires unpackaged dependencies
+url="https://github.com/mithrandi/txacme"
+arch="noarch"
+license="MIT"
+depends="
+ python3
+ py3-acme
+ py3-attrs
+ py3-eliot
+ py3-josepy
+ py3-pem
+ py3-treq
+ py3-twisted
+ py3-txsni
+ py3-openssl
+ "
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/t/txacme/txacme-$pkgver.tar.gz"
+builddir="$srcdir/txacme-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="efbe0563e5c6644c71c6c020428cd10b681b4a7b3cfba1b8475b74ad8503fb0defa24d028b1d37f24b11dfd3f90cc98c1e7318b8b1748142de9c51da00498e35 txacme-0.9.2.tar.gz"