aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-typed-ast/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-11-04 12:02:17 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-11-05 15:35:34 +0000
commitc240d3f1ca8dfe9d6af5d6a736da39b9a58ba6aa (patch)
treeba6db6599bf5a6f44a07f36c5895d4d6e0387229 /testing/py3-typed-ast/APKBUILD
parent171f6d33883ce50b656dc6b63ae6dec806b36c32 (diff)
downloadaports-c240d3f1ca8dfe9d6af5d6a736da39b9a58ba6aa.tar.bz2
aports-c240d3f1ca8dfe9d6af5d6a736da39b9a58ba6aa.tar.xz
testing/py3-typed-ast: rebuild against python 3.8
Diffstat (limited to 'testing/py3-typed-ast/APKBUILD')
-rw-r--r--testing/py3-typed-ast/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/py3-typed-ast/APKBUILD b/testing/py3-typed-ast/APKBUILD
index b74df43857..8fe013272a 100644
--- a/testing/py3-typed-ast/APKBUILD
+++ b/testing/py3-typed-ast/APKBUILD
@@ -3,7 +3,7 @@
pkgname=py3-typed-ast
_pkgname=typed_ast
pkgver=1.4.0
-pkgrel=0
+pkgrel=1
pkgdesc="Fork of the Python ast module with type comment support"
url="https://github.com/python/typed_ast"
arch="all"
@@ -21,13 +21,14 @@ build() {
# two (2) tests fail on s390x, disable
check() {
local _pyarch
+ local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
case "$CARCH" in
x86_64|aarch64|ppc64le) _pyarch="$CARCH" ;;
x86) _pyarch=i686 ;;
armhf|armv7) _pyarch=armv8l ;;
s390x) return 0 ;;
esac
- PYTHONPATH="$builddir/build/lib.linux-$_pyarch-3.7" py.test-3 -v
+ PYTHONPATH="$builddir/build/lib.linux-$_pyarch-$_py3ver" py.test-3 -v
}
package() {