aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-typed-ast
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-16 20:17:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-16 20:17:16 -0300
commit68d8fab3b5f06a1fff3b353f72c5a7d330805386 (patch)
treeb44636e4cec7437ecfba1f375b63e7620ed17dfc /testing/py3-typed-ast
parent9277c8e3a7292f5bf5855442ba81c649a5ae11bd (diff)
downloadaports-68d8fab3b5f06a1fff3b353f72c5a7d330805386.tar.bz2
aports-68d8fab3b5f06a1fff3b353f72c5a7d330805386.tar.xz
testing/py3-typed-ast: deal with x86 <-> i686 conversion by python3
Diffstat (limited to 'testing/py3-typed-ast')
-rw-r--r--testing/py3-typed-ast/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/testing/py3-typed-ast/APKBUILD b/testing/py3-typed-ast/APKBUILD
index 53838ec582..b55d10e81b 100644
--- a/testing/py3-typed-ast/APKBUILD
+++ b/testing/py3-typed-ast/APKBUILD
@@ -19,7 +19,11 @@ build() {
}
check() {
- PYTHONPATH="$builddir/build/lib.linux-$CARCH-3.7" py.test-3 -v
+ case "$CARCH" in
+ x86) _CARCH=i686 ;;
+ *) _CARCH="$CARCH" ;;
+ esac
+ PYTHONPATH="$builddir/build/lib.linux-$_CARCH-3.7" py.test-3 -v
}
package() {