aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-websockets
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2017-11-28 20:34:58 +0100
committerFrancesco Colista <fcolista@alpinelinux.org>2017-12-08 05:14:10 +0000
commite43b9db2bd37f6c06a4505f5c01d9e174360d4cf (patch)
tree319976acc0833d2f72bae47f941ebde27bc303b4 /testing/py3-websockets
parente2ab855691aa40ea404e993438d267197dc4ff78 (diff)
downloadaports-e43b9db2bd37f6c06a4505f5c01d9e174360d4cf.tar.bz2
aports-e43b9db2bd37f6c06a4505f5c01d9e174360d4cf.tar.xz
testing/py3-websockets: upgrade to 4.0.1; modernize
Diffstat (limited to 'testing/py3-websockets')
-rw-r--r--testing/py3-websockets/APKBUILD21
1 files changed, 13 insertions, 8 deletions
diff --git a/testing/py3-websockets/APKBUILD b/testing/py3-websockets/APKBUILD
index dad7f916b4..11a7c58ae0 100644
--- a/testing/py3-websockets/APKBUILD
+++ b/testing/py3-websockets/APKBUILD
@@ -2,26 +2,31 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-websockets
_pkgname=websockets
-pkgver=3.2
-pkgrel=1
+pkgver=4.0.1
+pkgrel=0
pkgdesc="An implementation of the WebSocket Protocol (RFC 6455)"
url="https://websockets.readthedocs.io"
-arch="noarch"
+arch="all"
license="BSD"
+options="!check" # tox is in testing
makedepends="python3-dev"
+checkdepends="py3-tox"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
cd "$builddir"
- python3 setup.py build || return 1
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ tox
}
package() {
cd "$builddir"
- python3 setup.py install --root="$pkgdir" --optimize=1 || return 1
+ python3 setup.py install --root="$pkgdir" --optimize=1
}
-md5sums="c1842c03d14169082e065a109fe1cb2c websockets-3.2.tar.gz"
-sha256sums="b536827d433a79e85108becdac0b0909e7ce02c3613df53da6d96aee950b50b5 websockets-3.2.tar.gz"
-sha512sums="fc8e3318139174faf6f6fc3065ecec536d8ebc5d328081c82371bfaf7538a4e67c43d5460d06852191532b105c0494adf7b18fd36ec55772d552f83737e25c1c websockets-3.2.tar.gz"
+sha512sums="a60a453f33f1005c7ec7cee10f6ba6cca18628306de51872ad5a910f12f39831049f3a67ff4c3cc62efce47ce030b9e9d075d4418e8da2dcc594b8824ce21dfb websockets-4.0.1.tar.gz"