aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-xlwt
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-03 20:08:13 +0300
committerprspkt <prspkt@protonmail.com>2019-06-03 20:08:16 +0300
commit90bfa9218e0e8e883f5351852846425b34435a46 (patch)
treee9395c5d781542db73034ac29c94367678923d1a /testing/py3-xlwt
parent5e4f2f068f8fb00d90c57c40c244f90c065b6787 (diff)
downloadaports-90bfa9218e0e8e883f5351852846425b34435a46.tar.bz2
aports-90bfa9218e0e8e883f5351852846425b34435a46.tar.xz
testing/py3-xlwt: modernize, fix provides
Diffstat (limited to 'testing/py3-xlwt')
-rw-r--r--testing/py3-xlwt/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/testing/py3-xlwt/APKBUILD b/testing/py3-xlwt/APKBUILD
index 662a71e018..967ba85206 100644
--- a/testing/py3-xlwt/APKBUILD
+++ b/testing/py3-xlwt/APKBUILD
@@ -3,25 +3,23 @@
pkgname=py3-xlwt
_pkgname=xlwt
pkgver=1.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A library to create spreadsheet files"
url="https://pypi.org/project/xlwt"
arch="noarch"
license="BSD-3-Clause BSD-4-Clause LGPL-2.1-or-later"
-provides="py-xlwt" # for backwards compatibility
-replaces="py-xlwt=$pkgver-r$pkgrel" # for backwards compatibility
-depends="py3-six python3"
-makedepends="py3-setuptools python3-dev"
+replaces="py-xlwt" # for backwards compatibility
+provides="py-xlwt=$pkgver-r$pkgrel" # for backwards compatibility
+depends="py3-six"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$builddir"
python3 setup.py build
}
package() {
- cd "$builddir"
python3 setup.py install --prefix=/usr --root="$pkgdir"
}