aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-zope-i18nmessageid
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:47:54 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:50:30 -0300
commit07da5b681a3102878a0447d0f5626d5bbd2807c6 (patch)
treedf7548dc7147abe5c7e4330b82372ffdd474af45 /testing/py3-zope-i18nmessageid
parenteeb3d86ff9c183dc335a06b7d8fc089b05999c65 (diff)
downloadaports-07da5b681a3102878a0447d0f5626d5bbd2807c6.tar.bz2
aports-07da5b681a3102878a0447d0f5626d5bbd2807c6.tar.xz
testing/py3-zope-i18nmessageid: new aport
https://github.com/zopefoundation/zope.i18nmessageid Message Identifiers for internationalization
Diffstat (limited to 'testing/py3-zope-i18nmessageid')
-rw-r--r--testing/py3-zope-i18nmessageid/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-zope-i18nmessageid/APKBUILD b/testing/py3-zope-i18nmessageid/APKBUILD
new file mode 100644
index 0000000000..2aa66ad788
--- /dev/null
+++ b/testing/py3-zope-i18nmessageid/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer:
+pkgname=py3-zope-i18nmessageid
+_pkgname=zope.i18nmessageid
+pkgver=4.3.1
+pkgrel=0
+pkgdesc="Message Identifiers for internationalization"
+url="https://github.com/zopefoundation/zope.i18nmessageid"
+arch="all"
+license="ZPL-2.1"
+depends="py3-setuptools py3-six"
+makedepends="python3-dev"
+checkdepends="py3-nose py3-coverage"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="3b01c6e25c2f2188e90a16556b263d45f590f61ec22e0ed87980a903109cb3f1c96a5fe5cdea9694d5c7508c5923b0faee0c8387aa947b5ab42720783089cb9f zope.i18nmessageid-4.3.1.tar.gz"