aboutsummaryrefslogtreecommitdiffstats
path: root/testing/qimgv/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 15:16:08 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-27 15:16:08 -0300
commit615a5c6a121603e12fda8a25bd9b7c679e33f948 (patch)
treee87e5cd033276e71345bd3a2bbc3802a033175bf /testing/qimgv/APKBUILD
parent66c3ee9a52a246e5464db3b0441db4d09f9d68f5 (diff)
downloadaports-615a5c6a121603e12fda8a25bd9b7c679e33f948.tar.bz2
aports-615a5c6a121603e12fda8a25bd9b7c679e33f948.tar.xz
testing/qimgv: upgrade to 0.8.2
Diffstat (limited to 'testing/qimgv/APKBUILD')
-rw-r--r--testing/qimgv/APKBUILD25
1 files changed, 20 insertions, 5 deletions
diff --git a/testing/qimgv/APKBUILD b/testing/qimgv/APKBUILD
index 95bccfbf05..2b65607725 100644
--- a/testing/qimgv/APKBUILD
+++ b/testing/qimgv/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=qimgv
-pkgver=0.7.3
+pkgver=0.8.2
pkgrel=0
pkgdesc="Cross-platform image viewer with webm support"
url="https://github.com/easymodo/qimgv"
@@ -8,12 +8,19 @@ options="!check"
arch="all"
license="GPL-3.0-or-later"
depends="hicolor-icon-theme"
-makedepends="qt5-qtbase-dev cmake"
-source="$pkgname-$pkgver.tar.gz::https://github.com/easymodo/qimgv/archive/v${pkgver}.tar.gz"
+depends_dev="qt5-qtbase-dev exiv2-dev mpv-dev"
+makedepends="$depends_dev cmake"
+subpackages="$pkgname-dev $pkgname-mpv"
+source="$pkgname-$pkgver.tar.gz::https://github.com/easymodo/qimgv/archive/v$pkgver.tar.gz"
build() {
mkdir build && cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DEXIV2=ON \
+ -DVIDEO_SUPPORT=ON \
+ -DKDE_SUPPORT=OFF
cmake --build .
}
@@ -22,4 +29,12 @@ package() {
cmake --build . --target install -- DESTDIR="$pkgdir"
}
-sha512sums="fae7986ce29941232dd2863a0900651fb3a7d6d184b05e763670b16c74bb0cc27ce6eb936b2a41a2183e3dc5c33006e3fe3491ed043c6e357ea31d6a716d80e0 qimgv-0.7.3.tar.gz"
+mpv() {
+ pkgdesc="$pkgdesc (mpv support)"
+ install_if="$pkgname=$pkgver-r$pkgrel mpv-libs"
+
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libqimgv_player_mpv.so.* "$subpkgdir"/usr/lib
+}
+
+sha512sums="e80caa356cd2c7607a1d92a4ef4a79486ed504adb8ae454557e6a94d1d3ca5c023b78921e49777b1a06ca82556255d51357948281aae6a671ec01c597492a2cf qimgv-0.8.2.tar.gz"