aboutsummaryrefslogtreecommitdiffstats
path: root/testing/racket
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-16 00:23:40 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-16 00:29:37 +0100
commita47cd132134c30bd30a48c7e72cafa5ac083dd85 (patch)
tree90a9f2445060f07405183a579a6c18e7f21a3a0b /testing/racket
parent14c42862bc4cc3175a55cfa4a915c2c00b3f746b (diff)
downloadaports-a47cd132134c30bd30a48c7e72cafa5ac083dd85.tar.bz2
aports-a47cd132134c30bd30a48c7e72cafa5ac083dd85.tar.xz
testing/racket: patch racket's openssl module to work with LibreSSL
Diffstat (limited to 'testing/racket')
-rw-r--r--testing/racket/APKBUILD8
-rw-r--r--testing/racket/libressl.patch49
2 files changed, 54 insertions, 3 deletions
diff --git a/testing/racket/APKBUILD b/testing/racket/APKBUILD
index b0175b0f32..84ed468c39 100644
--- a/testing/racket/APKBUILD
+++ b/testing/racket/APKBUILD
@@ -6,7 +6,7 @@
# TODO: Figure out how to run tests.
pkgname=racket
pkgver=6.12
-pkgrel=0
+pkgrel=1
pkgdesc="A general purpose programming language in the Lisp-Scheme family"
url="https://racket-lang.org/"
arch="all"
@@ -16,7 +16,8 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://download.racket-lang.org/releases/$pkgver/installers/$pkgname-minimal-$pkgver-src.tgz
paxmark.patch
musl-fixes.patch
- makefile-fix-bashism.patch"
+ makefile-fix-bashism.patch
+ libressl.patch"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -66,4 +67,5 @@ package() {
sha512sums="f342f0e475abb8ceb692cc66cde8d0741f0b106721210d427b569453ead642bbb951dd182378bcb468c53e170c2691cf05a64ccd49fc5a701ff24047874eb82a racket-minimal-6.12-src.tgz
ff7804e37cbab237921f7d4c334f6cbb2909e9284b7b2cec1dfd3e73ec189b8ecf0cb0cabd1abedb09020f2a57ad4c32088ea73e5cb71afdafce39a7a718b10c paxmark.patch
6af0ae984ac54f167f0513795905e9dc845e1c1554935f73958d4e21c5fad35eca791866cfdf94dfcee586ec28335d90520d769010c63cd6ab528e6be3f2c21c musl-fixes.patch
-1a96718e6a065bd08f0ff046e799fd4d7657d99789b2cdda8cf7cdd8c2d91742dd34fb43f4c6fabde89a764e073bdecdd96e2caeee49feaac242d30b17d6422b makefile-fix-bashism.patch"
+1a96718e6a065bd08f0ff046e799fd4d7657d99789b2cdda8cf7cdd8c2d91742dd34fb43f4c6fabde89a764e073bdecdd96e2caeee49feaac242d30b17d6422b makefile-fix-bashism.patch
+72fd6870c849e6f94a426041ccee0e94146c85e33fe7da4a4bdbc72f8b81fac846935f9abfe91170a91dc32180652ec1d0260ec94587e3480ce1fa578400f8f4 libressl.patch"
diff --git a/testing/racket/libressl.patch b/testing/racket/libressl.patch
new file mode 100644
index 0000000000..7470c6c652
--- /dev/null
+++ b/testing/racket/libressl.patch
@@ -0,0 +1,49 @@
+--- a/collects/openssl/libcrypto.rkt
++++ b/collects/openssl/libcrypto.rkt
+@@ -37,7 +37,12 @@
+ ;; Other specific known versions
+ "1.0.1k" "1.0.1j" "1.0.1g" "1.0.1e"
+ "1.0" "1.0.0" "1.0.0e" "1.0.0d" "1.0.0c" "1.0.0b" "1.0.0a"
+- "0.9.8e" "0.9.8b" "0.9.8" "0.9.7"))
++ "0.9.8e" "0.9.8b" "0.9.8" "0.9.7"
++
++ ;; LibreSSL
++ "42" ;; 2.6.3+
++ "41" ;; 2.5.5+
++))
+
+ (define libcrypto-load-fail-reason #f)
+
+--- a/collects/openssl/libssl.rkt
++++ b/collects/openssl/libssl.rkt
+@@ -9,6 +9,24 @@
+ (provide libssl
+ libssl-load-fail-reason)
+
++(define libssl-versions
++ '(;; Versionless (eg from devel pkg)
++ ""
++
++ ;; Compatibility-based version / SONAME
++ "10" ;; Fedora
++ "1.0.0" ;; Debian, Ubuntu
++
++ ;; Other specific known versions
++ "1.0.1k" "1.0.1j" "1.0.1g" "1.0.1e"
++ "1.0" "1.0.0" "1.0.0e" "1.0.0d" "1.0.0c" "1.0.0b" "1.0.0a"
++ "0.9.8e" "0.9.8b" "0.9.8" "0.9.7"
++
++ ;; LibreSSL
++ "44" ;; 2.6.3+
++ "43" ;; 2.5.3+
++))
++
+ (define libssl-load-fail-reason #f)
+
+ ;; We need to declare because they might be distributed with PLT Scheme
+@@ -28,4 +46,4 @@
+ (lambda (x)
+ (set! libssl-load-fail-reason (exn-message x))
+ #f)])
+- (ffi-lib libssl-so openssl-lib-versions))))
++ (ffi-lib libssl-so libssl-versions))))