aboutsummaryrefslogtreecommitdiffstats
path: root/testing/raspberrypi-bootloader
diff options
context:
space:
mode:
authorMarian Buschsieweke <m.buschsieweke@uni-muenster.de>2016-04-24 16:03:07 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-12-27 06:48:58 +0000
commit187e59cec643d2857f34fd15fb84fe5c4cd2ae18 (patch)
tree5855afecd61103f414b2c547a00f7fafd51b0948 /testing/raspberrypi-bootloader
parent0775b99be61e546c6fd295f30689bf14ce246707 (diff)
downloadaports-187e59cec643d2857f34fd15fb84fe5c4cd2ae18.tar.bz2
aports-187e59cec643d2857f34fd15fb84fe5c4cd2ae18.tar.xz
testing/raspberrypi-bootloader: new aport
https://github.com/raspberrypi/firmware raspberrypi-bootloader: Bootloader files for the Raspberry Pi raspberrypi-bootloader-x: Extra codecs for the Raspberry Pi
Diffstat (limited to 'testing/raspberrypi-bootloader')
-rw-r--r--testing/raspberrypi-bootloader/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/raspberrypi-bootloader/APKBUILD b/testing/raspberrypi-bootloader/APKBUILD
new file mode 100644
index 0000000000..079e401410
--- /dev/null
+++ b/testing/raspberrypi-bootloader/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Marian <mari.hahn@wwu.de>
+# Maintainer: Timo Teräs <timo.teras@iki.fi>
+pkgname=raspberrypi-bootloader
+_commit=d760a4ffd378c648ff5d9854e26dc868a5e1fd09
+pkgver=20161203
+pkgrel=0
+pkgdesc="Bootloader files for the Raspberry Pi"
+url=https://github.com/raspberrypi/firmware
+arch="armhf"
+license="custom"
+depends=""
+makedepends=""
+install=
+source="$pkgname-$pkgver.tar.gz::https://github.com/raspberrypi/firmware/archive/${_commit}.tar.gz"
+subpackages="$pkgname-x:bootloader_x"
+
+builddir="${srcdir}/firmware-${_commit}"
+package() {
+ cd "$builddir"/boot
+ mkdir -p "$pkgdir"/boot
+ cp bootcode.bin fixup.dat start.elf "$pkgdir"/boot/
+}
+
+bootloader_x() {
+ pkgdesc="Extra codecs for the Raspberry Pi"
+ depends="$pkgname"
+ cd "$builddir"/boot
+ mkdir -p "$subpkgdir"/boot
+ cp start_x.elf start_cd.elf start_db.elf fixup_x.dat fixup_cd.dat fixup_db.dat "$subpkgdir"/boot/
+}
+
+
+md5sums="ffa8fc62babc22fc1de724ff961b4d51 raspberrypi-bootloader-20161203.tar.gz"
+sha256sums="cc5ec6abea86d504ef0a931f2fbd452c979af1a4695e6fedde5bbcf5caefc32a raspberrypi-bootloader-20161203.tar.gz"
+sha512sums="e6626a4260a276a95cbc38525c911edb58b6c3fe1c57ee34adfbb970245ff3f99a5c3635a328f4799a886668273b0ba2002454dad300a97799bd974f9ea5a26a raspberrypi-bootloader-20161203.tar.gz"