aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rav1e
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-25 12:48:56 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-25 12:48:56 +0100
commit9cd1bc2af992a5c579800a90605d45571448349c (patch)
tree7cd627c711f757780b7018a19386a27e0f51e02c /testing/rav1e
parent9fa23921c38df4a5d2dc6da269c3b032e6ba83d3 (diff)
downloadaports-9cd1bc2af992a5c579800a90605d45571448349c.tar.bz2
aports-9cd1bc2af992a5c579800a90605d45571448349c.tar.xz
testing/rav1e: fix build on x86
Diffstat (limited to 'testing/rav1e')
-rw-r--r--testing/rav1e/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/rav1e/APKBUILD b/testing/rav1e/APKBUILD
index 153a2cc4d6..e38307b586 100644
--- a/testing/rav1e/APKBUILD
+++ b/testing/rav1e/APKBUILD
@@ -12,6 +12,10 @@ makedepends="cargo nasm"
subpackages="$pkgname-doc $pkgname-libs"
source="$pkgname-$pkgver.tar.gz::https://github.com/xiph/rav1e/archive/v$pkgver.tar.gz"
+case "$CARCH" in
+ x86) CFLAGS="$CFLAGS -fno-stack-protector" ;;
+esac
+
prepare() {
RUSTFLAGS="-C opt-level=0" \
cargo install --force --root "$srcdir" cargo-c