aboutsummaryrefslogtreecommitdiffstats
path: root/testing/rcm
diff options
context:
space:
mode:
authorkajisha <kajisha@gmail.com>2017-12-31 21:41:51 +0900
committerJakub Jirutka <jakub@jirutka.cz>2017-12-31 17:38:14 +0100
commit8ce69c3741812a68b8eb931f74925ac2bc8c06b2 (patch)
tree2500536ecf691526e337348a626b059b45d1a456 /testing/rcm
parentaa57baeaf6db40ac4652b170eb1c27953210ca04 (diff)
downloadaports-8ce69c3741812a68b8eb931f74925ac2bc8c06b2.tar.bz2
aports-8ce69c3741812a68b8eb931f74925ac2bc8c06b2.tar.xz
testing/rcm: new aport
https://github.com/thoughtbot/rcm rc file (dotfile) management
Diffstat (limited to 'testing/rcm')
-rw-r--r--testing/rcm/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/rcm/APKBUILD b/testing/rcm/APKBUILD
new file mode 100644
index 0000000000..7f57abb566
--- /dev/null
+++ b/testing/rcm/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Hiroshi Kajisha <kajisha@gmail.com>
+# Maintainer: Hiroshi Kajisha <kajisha@gmail.com>
+pkgname=rcm
+pkgver=1.3.1
+pkgrel=0
+pkgdesc="rc file (dotfile) management"
+url="https://github.com/thoughtbot/rcm"
+arch="noarch"
+license="BSD-3-Clause"
+makedepends="autoconf automake ruby-mustache"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/thoughtbot/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./autogen.sh
+ CONFIG_SHELL=/bin/sh ./configure --prefix=/usr
+ make -j1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="14ea8597efde30d286d2c020ff40cc3c2b61e57e50d20693f9402958284e3e709bf94706cc9c1ca74f5be9b0f5d8969ec21cd1e69efc553286bbf101ede03bd9 rcm-1.3.1.tar.gz"