aboutsummaryrefslogtreecommitdiffstats
path: root/testing/refind
diff options
context:
space:
mode:
authorEric Molitor <emolitor@molitor.org>2019-01-01 20:45:10 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 10:30:15 +0000
commit105aa1551d9ca9191a0a99078666c580d155f6b1 (patch)
tree30cad037930b01c07cfa32093098505aad1b2302 /testing/refind
parent7e23c2ea670378e2b90c34a70c190a6eb0326ef0 (diff)
downloadaports-105aa1551d9ca9191a0a99078666c580d155f6b1.tar.bz2
aports-105aa1551d9ca9191a0a99078666c580d155f6b1.tar.xz
testing/refind: new aport
https://www.rodsbooks.com/refind A fork of the rEFIt boot manager for computers based on the Extensible Firmware Interface (EFI) and Unified EFI (UEFI).
Diffstat (limited to 'testing/refind')
-rw-r--r--testing/refind/10-refind-disable-fortify.patch11
-rw-r--r--testing/refind/APKBUILD29
2 files changed, 40 insertions, 0 deletions
diff --git a/testing/refind/10-refind-disable-fortify.patch b/testing/refind/10-refind-disable-fortify.patch
new file mode 100644
index 0000000000..b59b711473
--- /dev/null
+++ b/testing/refind/10-refind-disable-fortify.patch
@@ -0,0 +1,11 @@
+--- refind-0.11.4-orig/libeg/Makefile
++++ refind-0.11.4/libeg/Makefile
+@@ -12,7 +12,7 @@
+
+ VPATH = $(SRCDIR)
+
+-LOCAL_GNUEFI_CFLAGS = -I$(SRCDIR) -I$(SRCDIR)/../include
++LOCAL_GNUEFI_CFLAGS = -D_FORTIFY_SOURCE=0 -I$(SRCDIR) -I$(SRCDIR)/../include
+
+ OBJS = nanojpeg.o nanojpeg_xtra.o screen.o image.o text.o load_bmp.o load_icns.o lodepng.o lodepng_xtra.o
+ TARGET = libeg.a
diff --git a/testing/refind/APKBUILD b/testing/refind/APKBUILD
new file mode 100644
index 0000000000..873d3554d6
--- /dev/null
+++ b/testing/refind/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eric Molitor <eric@molitor.org>
+pkgname=refind
+pkgver=0.11.4
+pkgrel=0
+pkgdesc="rEFInd EFI Boot Manager"
+url="http://www.rodsbooks.com/refind"
+arch="aarch64 x86 x86_64"
+options="!check" # No test suite.
+license="GPL-3.0"
+depends=""
+makedepends="gnu-efi-dev bash"
+source="https://sourceforge.net/projects/refind/files/${pkgver}/${pkgname}-src-${pkgver}.tar.gz
+ 10-refind-disable-fortify.patch"
+
+builddir="$srcdir/${pkgname}-${pkgver}"
+
+build() {
+ cd "$builddir"
+ make gnuefi
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 refind/refind_x64.efi $pkgdir/usr/share/refind/refind_x64.efi
+ install -Dm755 refind.conf-sample $pkgdir/usr/share/refind/refind.conf-sample
+ cp -r icons $pkgdir/usr/share/refind
+}
+sha512sums="529962ae432edaf1895ba98deb00a23c66bd742578e1a367f70f7ed22dd7be7daf1960df8af410fba79ca775169120499a4c10119331b2b12b55a002d4354de1 refind-src-0.11.4.tar.gz
+ccb61e6e5ae0d762932941d7edd5b9a3506db42cfce70ebc57468837799e60fee73b3c568ae603a6ebb677ae702fb5beb5d13b16daf976b954b35047b6f4ecc0 10-refind-disable-fortify.patch"