aboutsummaryrefslogtreecommitdiffstats
path: root/testing/screenfetch
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:49:21 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-10-09 00:51:35 +0200
commit5caea9ba3df6a65e8c2a2627ef7963970d42e326 (patch)
treed46b0d79570a586824a436be164b1df74dbb268d /testing/screenfetch
parente46b20de06a3db083a465da855b3c405435a9e97 (diff)
downloadaports-5caea9ba3df6a65e8c2a2627ef7963970d42e326.tar.bz2
aports-5caea9ba3df6a65e8c2a2627ef7963970d42e326.tar.xz
testing/screenfetch: new aport
https://github.com/KittyKatt/screenFetch Fetches system/theme information in terminal for Linux desktop screenshots
Diffstat (limited to 'testing/screenfetch')
-rw-r--r--testing/screenfetch/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/screenfetch/APKBUILD b/testing/screenfetch/APKBUILD
new file mode 100644
index 0000000000..b129417708
--- /dev/null
+++ b/testing/screenfetch/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=screenfetch
+_pkgname=screenFetch
+pkgver=3.8.0
+pkgrel=0
+pkgdesc="Fetches system/theme information in terminal for Linux desktop screenshots"
+url="https://github.com/KittyKatt/screenFetch"
+arch="all"
+license="GPL-3.0"
+depends="bash bc"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/KittyKatt/$_pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # no tests provided by upstream
+
+package() {
+ cd "$builddir"
+
+ install -m 755 -D screenfetch-dev "$pkgdir"/usr/bin/$pkgname
+ install -m 644 -D $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+sha512sums="903f42e3bfcd719c4d6b91d10e5678063e223c2baa58214c7e8dae9ea925852f9e2c07ad90148e02d87ce5f9af7b989e80e93c2f569cd579e6f4f7d5c49c62f2 screenfetch-3.8.0.tar.gz"