aboutsummaryrefslogtreecommitdiffstats
path: root/testing/seamonkey
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-08-22 12:40:06 +0200
committerJakub Jirutka <jakub@jirutka.cz>2016-08-22 12:40:06 +0200
commit43aed370e1b3e77fd1ac158866ed60795088e1f3 (patch)
treee10564aed1db06b4811d6b688c0e61fc3369680c /testing/seamonkey
parenta48c900cc4b9537b493ef8e2976331ebe4dc104b (diff)
downloadaports-43aed370e1b3e77fd1ac158866ed60795088e1f3.tar.bz2
aports-43aed370e1b3e77fd1ac158866ed60795088e1f3.tar.xz
testing/seamonkey: fix build error with detecting shell
Diffstat (limited to 'testing/seamonkey')
-rw-r--r--testing/seamonkey/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/testing/seamonkey/APKBUILD b/testing/seamonkey/APKBUILD
index 418e21175d..8f3eb2cb19 100644
--- a/testing/seamonkey/APKBUILD
+++ b/testing/seamonkey/APKBUILD
@@ -5,7 +5,7 @@ pkgver=2.40
pkgrel=0
pkgdesc="all-in-one internet application suite"
url="http://www.seamonkey-project.org"
-arch=""
+arch="all"
license="MPL"
depends=""
makedepends="unzip zip gtk+2.0-dev yasm alsa-lib-dev pulseaudio-dev libxt-dev
@@ -38,6 +38,8 @@ build() {
cp ../../mozconfig .mozconfig
export MOZ_MAKE_FLAGS="$MAKEFLAGS"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/seamonkey-$pkgver"
+ # Needed for mozilla/python/mach/mach/mixin/process.py
+ export SHELL="/bin/ash"
# Disable null pointer gcc6 optimization in gcc6 (rhbz#1328045)
MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -fno-delete-null-pointer-checks"
unset MAKEFLAGS CPPFLAGS