aboutsummaryrefslogtreecommitdiffstats
path: root/testing/seamonkey
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-22 10:58:52 +0200
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-22 10:58:57 +0200
commitb79c5fb5843753adc5dcae4ee55860772e7a5d0e (patch)
treedace0d3e0347255607e19d2847b3c3910a488cdf /testing/seamonkey
parent3ab89df0030d905def63177ebc928ec23494fcfe (diff)
downloadaports-b79c5fb5843753adc5dcae4ee55860772e7a5d0e.tar.bz2
aports-b79c5fb5843753adc5dcae4ee55860772e7a5d0e.tar.xz
testing/seamonkey: build fix gcc6
Diffstat (limited to 'testing/seamonkey')
-rw-r--r--testing/seamonkey/APKBUILD58
-rw-r--r--testing/seamonkey/firefox-gcc-6.0.patch26
2 files changed, 53 insertions, 31 deletions
diff --git a/testing/seamonkey/APKBUILD b/testing/seamonkey/APKBUILD
index 32681bc891..a09d4eee97 100644
--- a/testing/seamonkey/APKBUILD
+++ b/testing/seamonkey/APKBUILD
@@ -9,50 +9,43 @@ arch="all"
license="MPL"
depends=""
depends_dev="unzip zip gtk+2.0-dev yasm alsa-lib-dev pulseaudio-dev
-libxt-dev hunspell-dev nspr-dev nss-dev jpeg-dev bzip2-dev zlib-dev libpng-dev
-libevent-dev libvpx-dev sqlite-dev libffi-dev pixman-dev
-startup-notification-dev icu-dev"
+ libxt-dev hunspell-dev nspr-dev nss-dev jpeg-dev bzip2-dev zlib-dev libpng-dev
+ libevent-dev libvpx-dev sqlite-dev libffi-dev pixman-dev
+ startup-notification-dev icu-dev m4 libxcomposite-dev"
makedepends="$depends_dev"
install=""
subpackages=""
source=" https://archive.mozilla.org/pub/mozilla.org/seamonkey/releases/$pkgver/source/seamonkey-$pkgver.source.tar.xz
-mozconfig
+ mozconfig
-fix-aouth.patch
-fix-libgen.patch
-fix-linux-syscall.patch
-fix-mallinfo.patch
-fix-platform-gettid.patch
-fix-platform-linux.patch
-fix-siginfo_t.patch
-fix-stabs.patch
-fix-sysctl.patch
-fix-system-headers.patch
-"
+ fix-aouth.patch
+ fix-libgen.patch
+ fix-linux-syscall.patch
+ fix-mallinfo.patch
+ fix-platform-gettid.patch
+ fix-platform-linux.patch
+ fix-siginfo_t.patch
+ fix-stabs.patch
+ fix-sysctl.patch
+ fix-system-headers.patch
+ firefox-gcc-6.0.patch
+ "
-_builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- cd "$_builddir"
- local i
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir/$i" || return 1;;
- esac
- done
-}
+builddir="$srcdir/$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
cp ../../mozconfig .mozconfig
export MOZ_MAKE_FLAGS="$MAKEFLAGS"
export LDFLAGS="$LDFLAGS -Wl,-rpath,/usr/lib/seamonkey-$pkgver"
+ # Disable null pointer gcc6 optimization in gcc6 (rhbz#1328045)
+ MOZ_OPT_FLAGS="$MOZ_OPT_FLAGS -fno-delete-null-pointer-checks"
unset MAKEFLAGS CPPFLAGS
make -f client.mk build
}
package() {
- cd "$_builddir"
+ cd "$builddir"
paxmark -msp */dist/bin/xpcshell
make -f client.mk DESTDIR="$pkgdir" INSTALL_SDK= install
paxmark -msp "$pkgdir/usr/lib/seamonkey-$pkgver/seamonkey"
@@ -86,7 +79,8 @@ b7b7f7ea1b9c5f427e40d17155a1ac7a fix-linux-syscall.patch
efa62f03c01f6c1da3dc59663b872e97 fix-siginfo_t.patch
3a72587709ba0f04c782b6c36c597b92 fix-stabs.patch
5c96430b83fb008750ba943944b96aed fix-sysctl.patch
-b23f1511dfc54d84fdc8346c595b7499 fix-system-headers.patch"
+b23f1511dfc54d84fdc8346c595b7499 fix-system-headers.patch
+2a8813b97256180bdbf5eed1a1ec3fab firefox-gcc-6.0.patch"
sha256sums="7ecccc039d03f38d197b123b59ea42eac4c0c10e4bdec779b3665d79b435fa01 seamonkey-2.40.source.tar.xz
61eff85a616ffd4325d75d2d7871fe8bf2f8faa31b0a64b29c6d255ce891a5d5 mozconfig
b6224ec48fa5250652b4dcbb4c2eae34cd02486f73327774a59652911909f956 fix-aouth.patch
@@ -98,7 +92,8 @@ cabab41e8003f5445b178d59cb0b594e7c9c0009fb842be275adbd749efa5fcb fix-platform-l
f2cc65f42bd672ff1cbf4904def0ce4d99b7776dc2e2d7cc1c8bd2dcee47ed83 fix-siginfo_t.patch
04475564fa7df52b90afa5bfbf9381f50f1732a4073246f3cf268aa691f7b38c fix-stabs.patch
25493bf4d09b845102a7af9d606612c0ff8d053826da4ed6728c8a4875bdd3c6 fix-sysctl.patch
-a489572c350184e9f6cf639756e602bc96df8681c3d5a4ce4629ac5964009692 fix-system-headers.patch"
+a489572c350184e9f6cf639756e602bc96df8681c3d5a4ce4629ac5964009692 fix-system-headers.patch
+4ce72332ef13a176c3406c9541a5d67c10224b2b71b105ef831d880f7046c3ff firefox-gcc-6.0.patch"
sha512sums="5a81a25c75af254f1508aa615a082f013d7d06950859822a134c51a0f4c12918081f69e7835dc85114e4285a67bc4be4d509db8374dec848f6381dfce447b696 seamonkey-2.40.source.tar.xz
05e8818d3a4e2967b7ac3e92e92a125172d870326b9bf1fdd606a44e87ae8254684f2c5e2b0bb8df34c767fe62dc05950bf52447a39b4abf009ab88a8143832e mozconfig
b4c2bffec161c53087eec8bd0612095b52e514511d0f556387f1c3244a999c255da1a5f775573d86be82718ba09d3eb5aa7390b8aeb8f67c8b1b9f83e6ab16b6 fix-aouth.patch
@@ -110,4 +105,5 @@ fd6b68082843a17a97a09953f24f74e72090acbcd245e8564ffe41ed5cb0a7afbf3dfc653a6e33a5
285e9330810b0f57ebba3d15cb371543840a7c6b8a2656d6d6b3ad7e8d2ec840b34bcb75b92c3747b5a1b42625fbde3a5d1bbec7052ce47fe5455e5076ec6268 fix-siginfo_t.patch
4a7fae85299969618d729021ed79ab312650419dd849800c4e93c2b78a063a91f4003e2ee66c74abefa28b881376cf78f52e99e5ae3c08b85ba11eeae73a5034 fix-stabs.patch
43e800bdb15a11c21f71d0552ae2e92ad97574eb324f7be75cc92ed98332201386f9c9846d3e5f27b4e71452ffac71ab5b82ffdc2091d6c4830b9cb792bbdde4 fix-sysctl.patch
-d65900a74901d0455266342e4efbb655d67c62b52e69f482c33c3da3e24af900a3186f1398b88cccd9e822395480cd4ec4ce0d6053978003911457cacc36f767 fix-system-headers.patch"
+d65900a74901d0455266342e4efbb655d67c62b52e69f482c33c3da3e24af900a3186f1398b88cccd9e822395480cd4ec4ce0d6053978003911457cacc36f767 fix-system-headers.patch
+664983718ba4ed2588850f499cc7da94f2b35d384b6655b1e5ec118e45e8cbd108aa2b9e04cc4b902f4ddba2e1be2cffb056643e053761bfc6da92c942f30305 firefox-gcc-6.0.patch"
diff --git a/testing/seamonkey/firefox-gcc-6.0.patch b/testing/seamonkey/firefox-gcc-6.0.patch
new file mode 100644
index 0000000000..6b02e59dd8
--- /dev/null
+++ b/testing/seamonkey/firefox-gcc-6.0.patch
@@ -0,0 +1,26 @@
+diff -up ./mozilla/nsprpub/config/make-system-wrappers.pl.back firefox-44.0/nsprpub/config/make-system-wrappers.pl
+--- ./mozilla/nsprpub/config/make-system-wrappers.pl.back 2016-01-24 00:23:49.000000000 +0100
++++ ./mozilla/nsprpub/config/make-system-wrappers.pl 2016-02-02 14:58:45.064112655 +0100
+@@ -19,7 +19,9 @@ while (<STDIN>) {
+ open OUT, ">$output_dir/$_";
+ print OUT "#pragma GCC system_header\n"; # suppress include_next warning
+ print OUT "#pragma GCC visibility push(default)\n";
++ print OUT "#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
+ print OUT "#include_next \<$_\>\n";
++ print OUT "#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS\n";
+ print OUT "#pragma GCC visibility pop\n";
+ close OUT;
+ }
+diff -up firefox-44.0/mozglue/build/arm.cpp.old firefox-44.0/mozglue/build/arm.cpp
+--- ./mozilla/mozglue/build/arm.cpp.old 2016-02-03 10:07:29.879526500 +0100
++++ ./mozilla/mozglue/build/arm.cpp 2016-02-03 10:08:11.062697517 +0100
+@@ -104,7 +104,9 @@ check_neon(void)
+
+ # elif defined(__linux__) || defined(ANDROID)
+ # include <stdio.h>
++#define _GLIBCXX_INCLUDE_NEXT_C_HEADERS
+ # include <stdlib.h>
++#undef _GLIBCXX_INCLUDE_NEXT_C_HEADERS
+ # include <string.h>
+
+ enum{