aboutsummaryrefslogtreecommitdiffstats
path: root/testing/shunit2/APKBUILD
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-10-08 10:20:51 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-08 20:14:39 +0000
commit88b46f01876e5d7f0878e00c772ba71365f75b1b (patch)
treef90e27c839e6d43495689167197d7f2e1c184c19 /testing/shunit2/APKBUILD
parentd7536614fdd311855aca0f568bdaee6730770155 (diff)
downloadaports-88b46f01876e5d7f0878e00c772ba71365f75b1b.tar.bz2
aports-88b46f01876e5d7f0878e00c772ba71365f75b1b.tar.xz
testing/shunit2: Remove (incorrect) shell globing
The test framework of shunit2 needs to have the TMPDIR variable set correctly. As we want to ensure we scope the temporary directory properly, lets create our own temporary path using mktemp and pass this to shunit2. We can now cleanly remove whatever is in this path. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl> Closes !300
Diffstat (limited to 'testing/shunit2/APKBUILD')
-rw-r--r--testing/shunit2/APKBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/testing/shunit2/APKBUILD b/testing/shunit2/APKBUILD
index 7ca3e8d304..f0fd60851c 100644
--- a/testing/shunit2/APKBUILD
+++ b/testing/shunit2/APKBUILD
@@ -12,9 +12,9 @@ subpackages="${pkgname}-doc"
source="${pkgname}-${pkgver}.tar.gz::https://github.com/kward/shunit2/archive/v${pkgver}.tar.gz"
check() {
- _tmpdir="${TMPDIR:-/tmp/}"
- TMPDIR="$(mktemp -d -p "${_tmpdir}" shunit2.XXXXXXXX)" ./gen_test_report.sh
- rm -rf "${_tmpdir}/shunit2.*"
+ _tmpdir="$(mktemp -d -p "${TMPDIR:-/tmp/}" shunit2.XXXXXXXX)"
+ TMPDIR="${_tmpdir}" ./gen_test_report.sh
+ rm -rf "${_tmpdir}"
}
package() {