aboutsummaryrefslogtreecommitdiffstats
path: root/testing/snapper/musl-boost.patch
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2018-05-03 18:23:08 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2018-05-03 18:25:26 +0000
commitf8369be0c2fb7941156cf6f5a1143c5f91c5eb1a (patch)
tree8a0784e2007c551d83b01ee34e5a38ef059f84a8 /testing/snapper/musl-boost.patch
parent45b5690ccb0ec88c2742a5b3078b60655923d268 (diff)
downloadaports-f8369be0c2fb7941156cf6f5a1143c5f91c5eb1a.tar.bz2
aports-f8369be0c2fb7941156cf6f5a1143c5f91c5eb1a.tar.xz
testing/snapper: new aport
Diffstat (limited to 'testing/snapper/musl-boost.patch')
-rw-r--r--testing/snapper/musl-boost.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/snapper/musl-boost.patch b/testing/snapper/musl-boost.patch
new file mode 100644
index 0000000000..a4e9177bcf
--- /dev/null
+++ b/testing/snapper/musl-boost.patch
@@ -0,0 +1,49 @@
+diff --git a/examples/c++-lib/Makefile.am b/examples/c++-lib/Makefile.am
+index 52c81e5..715de51 100644
+--- a/examples/c++-lib/Makefile.am
++++ b/examples/c++-lib/Makefile.am
+@@ -5,7 +5,7 @@
+ AM_CPPFLAGS = -I$(top_srcdir)
+
+ LDADD = ../../snapper/libsnapper.la
+-AM_LDFLAGS = -lboost_system
++AM_LDFLAGS = -lboost_system-mt
+
+ noinst_PROGRAMS = List ListAll Create CmpDirs CreateNumber CreateTimeline
+
+diff --git a/server/Makefile.am b/server/Makefile.am
+index 2a6a4c2..e007710 100644
+--- a/server/Makefile.am
++++ b/server/Makefile.am
+@@ -14,4 +14,4 @@ snapperd_SOURCES = \
+ Types.cc Types.h
+
+ snapperd_LDADD = ../snapper/libsnapper.la ../dbus/libdbus.la -lrt
+-snapperd_LDFLAGS = -lboost_system -lboost_thread
++snapperd_LDFLAGS = -lboost_system-mt -lboost_thread-mt
+diff --git a/testsuite-cmp/Makefile.am b/testsuite-cmp/Makefile.am
+index 81104bf..d88644e 100644
+--- a/testsuite-cmp/Makefile.am
++++ b/testsuite-cmp/Makefile.am
+@@ -3,7 +3,7 @@
+ #
+
+ AM_CPPFLAGS = -I$(top_srcdir)
+-AM_LDFLAGS = -lboost_system
++AM_LDFLAGS = -lboost_system-mt
+
+ LDADD = ../snapper/libsnapper.la
+
+diff --git a/snapper/Makefile.am b/snapper/Makefile.am
+index 36467da..cb05a3b 100644
+--- a/snapper/Makefile.am
++++ b/snapper/Makefile.am
+@@ -62,7 +62,7 @@ libsnapper_la_SOURCES += \
+ endif
+
+ libsnapper_la_LDFLAGS = -version-info @LIBVERSION_INFO@
+-libsnapper_la_LIBADD = -lboost_thread -lboost_system -lxml2 -lacl -lz -lm
++libsnapper_la_LIBADD = -lboost_thread-mt -lboost_system-mt -lxml2 -lacl -lz -lm
+ if ENABLE_ROLLBACK
+ libsnapper_la_LIBADD += -lmount
+ endif