aboutsummaryrefslogtreecommitdiffstats
path: root/testing/spdlog
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-08-09 23:39:47 +0300
committerLeo <thinkabit.ukim@gmail.com>2019-08-09 18:00:41 -0300
commitd075e9d5b095c6efdb01296d01ad2cdf551be686 (patch)
tree4bc93c1a4ba0541d37ffc08b61c7e2035a88d183 /testing/spdlog
parentb5b60123bfbcba04698f16083b9827bd06b9abd3 (diff)
downloadaports-d075e9d5b095c6efdb01296d01ad2cdf551be686.tar.bz2
aports-d075e9d5b095c6efdb01296d01ad2cdf551be686.tar.xz
testing/spdlog: run test suite
Signed-off-by: prspkt <prspkt@protonmail.com>
Diffstat (limited to 'testing/spdlog')
-rw-r--r--testing/spdlog/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/spdlog/APKBUILD b/testing/spdlog/APKBUILD
index c81595be14..0e4a507c26 100644
--- a/testing/spdlog/APKBUILD
+++ b/testing/spdlog/APKBUILD
@@ -4,7 +4,6 @@ pkgname=spdlog
pkgver=1.3.1
pkgrel=0
pkgdesc="Fast C++ logging library"
-options="!check" # Unable to run tests
url="https://github.com/gabime/spdlog"
arch="all"
license="MIT"
@@ -26,15 +25,21 @@ build() {
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
-DSPDLOG_BUILD_EXAMPLES=OFF \
-DSPDLOG_BUILD_BENCH=OFF \
- -DSPDLOG_BUILD_TESTS=OFF \
+ -DSPDLOG_BUILD_TESTS=ON \
-DSPDLOG_SANITIZE_ADDRESS=OFF \
-DSPDLOG_FMT_EXTERNAL=OFF \
${CMAKE_CROSSOPTS} ..
make
}
+check() {
+ cd build
+ make test
+}
+
package() {
mkdir -p "$pkgdir"
make -C build DESTDIR="$pkgdir" install
}
+
sha512sums="a851a44b6384f493dd312ae0a611d068af46bbfe8daf1c2f61f13d8836a3801f41b339074fbe8da8e428131c82fa5c4a9e3320a55cbdd4b7aff8bb349dfff7dd spdlog-1.3.1.tar.gz"