aboutsummaryrefslogtreecommitdiffstats
path: root/testing/spin
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-29 23:12:02 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-30 00:22:51 -0300
commit82b013aef0c37087933f020d1cff75b41229f952 (patch)
tree88d1f3fbd19d04a057575bf5c0181e053e2609d9 /testing/spin
parented13dd2a38b6af14e32fa71c5949f26b8818a311 (diff)
downloadaports-82b013aef0c37087933f020d1cff75b41229f952.tar.bz2
aports-82b013aef0c37087933f020d1cff75b41229f952.tar.xz
testing/spin: upgrade to 6.4.9
Diffstat (limited to 'testing/spin')
-rw-r--r--testing/spin/APKBUILD16
-rw-r--r--testing/spin/makefile.patch20
2 files changed, 4 insertions, 32 deletions
diff --git a/testing/spin/APKBUILD b/testing/spin/APKBUILD
index 9a667da4b9..80c97b1669 100644
--- a/testing/spin/APKBUILD
+++ b/testing/spin/APKBUILD
@@ -1,36 +1,28 @@
# Contributor: Daniel Sabogal <dsabogalcc@gmail.com>
# Maintainer:
pkgname=spin
-pkgver=6.4.5
+pkgver=6.4.9
_pkgver=${pkgver//./}
pkgrel=0
pkgdesc="Tool for formal verification of distributed software systems"
+options="!check" # No testsuite
url="http://spinroot.com/"
arch="x86 x86_64 ppc64le"
license="BSD"
-depends=""
makedepends="bison"
subpackages="$pkgname-doc"
-source="http://spinroot.com/spin/Src/$pkgname$_pkgver.tar.gz
- makefile.patch"
+source="http://spinroot.com/spin/Src/$pkgname$_pkgver.tar.gz"
builddir="$srcdir/Spin"
build() {
make -C "$builddir/Src$pkgver"
}
-check() {
- cd "$builddir"
- ./Src$pkgver/spin -V
-}
-
package() {
- cd "$builddir"
install -d "$pkgdir"/usr/share/man/man1
install -d "$pkgdir"/usr/bin
install -m644 Man/spin.1 "$pkgdir"/usr/share/man/man1
install -m755 "Src$pkgver"/spin "$pkgdir"/usr/bin
}
-sha512sums="77bc35bb852c0448915c655bf11910d0b226d30d66abaa63311e6227de03f920ca026e7399cbeebdae631368fd8091f1e8330bd3094bd4febdf7d5c7a81834ad spin645.tar.gz
-de6e395714439e3e6e4d10dd25d9f3c2566ec7aa9ac58452a468a73c92690094f2df4c6e1a1425295a575e142764a33b7f86a2d2ea9788cfa23b84ff60bc43d6 makefile.patch"
+sha512sums="f7f9c2dc7cc89518f5845da8bb9f08a8f49567847a36a683b815bc9a7baa8892a1850937c29a44d20a454f4357f7b717b83797959de7fa3f027ec7f7f0bfebc3 spin649.tar.gz"
diff --git a/testing/spin/makefile.patch b/testing/spin/makefile.patch
deleted file mode 100644
index 1e01f4f8d2..0000000000
--- a/testing/spin/makefile.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- Spin/Src6.4.5/makefile.orig
-+++ Spin/Src6.4.5/makefile
-@@ -7,8 +7,6 @@
- # see also ./make_pc for a simpler script not requiring make
- # for 32-bit compilation, use ./make32
-
--CC=gcc
--CFLAGS=-O2 -DNXT # on some systems add: -I/usr/include
- # on a PC: add -DPC
- # on Solaris: add -DSOLARIS
- # on a Mac: add -DMAC
-@@ -37,7 +35,7 @@
- tl_mem.o tl_rewrt.o tl_cache.o
-
- spin: $(SPIN_OS) $(TL_OS) spin.o
-- $(CC) $(CFLAGS) -o spin spin.o $(SPIN_OS) $(TL_OS)
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o spin spin.o $(SPIN_OS) $(TL_OS)
-
- install: spin
- cp spin /usr/local/bin