aboutsummaryrefslogtreecommitdiffstats
path: root/testing/subtitleeditor
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2020-04-20 21:09:27 +0200
committerFrancesco Colista <fcolista@alpinelinux.org>2020-04-20 20:15:57 +0000
commit726b8a54ecd842fb732e3f78cfbc9f454aba92a4 (patch)
treece750df3ce3a9d612f56536813c2003221594150 /testing/subtitleeditor
parentbfec915c0dffc7bc6007f793aa2f4b9519f84d65 (diff)
downloadaports-726b8a54ecd842fb732e3f78cfbc9f454aba92a4.tar.bz2
aports-726b8a54ecd842fb732e3f78cfbc9f454aba92a4.tar.xz
testing/subtitleeditor: build against enchant2
Diffstat (limited to 'testing/subtitleeditor')
-rw-r--r--testing/subtitleeditor/APKBUILD11
-rw-r--r--testing/subtitleeditor/enchant2.patch41
2 files changed, 48 insertions, 4 deletions
diff --git a/testing/subtitleeditor/APKBUILD b/testing/subtitleeditor/APKBUILD
index f3903b4380..59e3986f87 100644
--- a/testing/subtitleeditor/APKBUILD
+++ b/testing/subtitleeditor/APKBUILD
@@ -2,17 +2,19 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=subtitleeditor
pkgver=0.54.0
-pkgrel=1
+pkgrel=2
pkgdesc="GTK+3 tool to create and edit subtitles"
url="https://kitone.github.io/subtitleeditor/"
arch="x86 x86_64"
license="GPL-3.0-or-later"
-makedepends="libxml++-2.6-dev enchant-dev libsigc++-dev xdg-utils gtkmm3-dev
+makedepends="libxml++-2.6-dev enchant2-dev libsigc++-dev xdg-utils gtkmm3-dev
gtk+3.0-dev gst-plugins-base-dev gstreamer-dev gstreamermm-dev iso-codes-dev
gst-libav desktop-file-utils gst-plugins-ugly automake autoconf libtool
intltool"
subpackages="$pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/kitone/subtitleeditor/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/kitone/subtitleeditor/archive/$pkgver.tar.gz
+ enchant2.patch
+ "
prepare() {
default_prepare
@@ -35,4 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="bea4610ccc452555be6eb1105601bfba767f849044c27e393687d3a698e8e14247278377464a57ff89b91c452cd428650dc014085fc70486106c16b294b072cd subtitleeditor-0.54.0.tar.gz"
+sha512sums="bea4610ccc452555be6eb1105601bfba767f849044c27e393687d3a698e8e14247278377464a57ff89b91c452cd428650dc014085fc70486106c16b294b072cd subtitleeditor-0.54.0.tar.gz
+f27484a999e61eea8375b9fa9b4daf7c2d6137eb27352dee634a66cc85eb20e25a2cdd50f0ececc45fb6b85d5ae4f73a775c68381937f1db85ef9f501902a79a enchant2.patch"
diff --git a/testing/subtitleeditor/enchant2.patch b/testing/subtitleeditor/enchant2.patch
new file mode 100644
index 0000000000..bf167ed7ba
--- /dev/null
+++ b/testing/subtitleeditor/enchant2.patch
@@ -0,0 +1,41 @@
+Backported from upstream master.
+
+Patch below is alterned to revert commit 5e9525c41272e850cbba0f65ce5809e5167880f2
+
+
+From 1dd00d036344f72ab8d647d3f5614940c95e2384 Mon Sep 17 00:00:00 2001
+From: Nikolay Shaplov <dhyan@nataraj.su>
+Date: Sat, 30 Nov 2019 20:57:57 +0300
+Subject: [PATCH] Fix build with old version of enchant, take two
+
+enchant-2 is not wide spread enough, for example debian have it only in experemental repo now.
+So it would be wise to make it possible to buld subtitleeditor with both enchant and echant-2
+---
+ configure.ac | 13 ++++++++++---
+ 1 file changed, 10 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index bfe30a3..beddd65 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -74,10 +74,17 @@ AC_SUBST(GTKMM_LIBS)
+ # =========================================================================
+ # check enchant
+
+-PKG_CHECK_MODULES(ENCHANT, enchant >= 1.4.0)
++PKG_CHECK_MODULES(ENCHANT2, enchant-2 >= 2.2.0, have_enchant_2=yes, have_enchant_2=no)
+
+-AC_SUBST(ENCHANT_CFLAGS)
+-AC_SUBST(ENCHANT_LIBS)
++if test "x$have_enchant_2" = "xyes"; then
++ ENCHANT_CFLAGS=$ENCHANT2_CFLAGS
++ ENCHANT_LIBS=$ENCHANT2_LIBS
++ AC_SUBST(ENCHANT_CFLAGS)
++ AC_SUBST(ENCHANT_LIBS)
++
++else
++ PKG_CHECK_MODULES(ENCHANT, enchant >= 1.4.0)
++fi
+
+ # =========================================================================
+ # check libxml++