aboutsummaryrefslogtreecommitdiffstats
path: root/testing/surf
diff options
context:
space:
mode:
authorOrson Teodoro <orsonteodoro@hotmail.com>2018-02-16 13:40:21 -0800
committerSören Tempel <soeren+git@soeren-tempel.net>2018-02-20 09:56:46 +0100
commit8076e9a97238c8a9245231efe96135d49ea4156a (patch)
treeab611875380b7db247c2ce1cb4ecbd855c06383d /testing/surf
parent17e281c1687d7940aeca40b8ced8d684aac0fda5 (diff)
downloadaports-8076e9a97238c8a9245231efe96135d49ea4156a.tar.bz2
aports-8076e9a97238c8a9245231efe96135d49ea4156a.tar.xz
testing/surf: new package
Diffstat (limited to 'testing/surf')
-rw-r--r--testing/surf/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/surf/APKBUILD b/testing/surf/APKBUILD
new file mode 100644
index 0000000000..d8e95ce1f5
--- /dev/null
+++ b/testing/surf/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
+# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
+pkgname=surf
+pkgver=2.0
+pkgrel=0
+pkgdesc="surf is a simple web browser based on WebKit2/GTK+."
+url="https://surf.suckless.org/"
+arch="all"
+license="MIT"
+depends="xprop"
+makedepends="webkit2gtk-dev"
+options="!check" # upstream doesn't have a test suite
+source="$pkgname-$pkgver.tar.gz::https://dl.suckless.org/$pkgname/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$pkgname-$pkgver
+subpackages="$pkgname-doc"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+
+ mkdir -p "$pkgdir"/usr/share/doc/$pkgname
+ install -m644 README TODO.md \
+ "$pkgdir"/usr/share/doc/$pkgname
+}
+
+sha512sums="75798bb189fa2c2c93827672089a86cf155aa7b5c7c1a0887a34817ca41763907e44a02f52947535d37a043f827d2c0fe75d16a3d172079f9cab8da341e4c0c5 surf-2.0.tar.gz"