aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sxhkd
diff options
context:
space:
mode:
authorOlivier Mauras <olivier@mauras.ch>2015-03-25 22:28:06 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2015-03-30 14:19:57 +0000
commit82b9c6a93fa49a2581dcdfb5bedb83210007c06c (patch)
treed98400529f2b7e0d0797f574407091a9f26cacc5 /testing/sxhkd
parent39d34c6c8ca1b74523d3748a5e4a0db2d103fde9 (diff)
downloadaports-82b9c6a93fa49a2581dcdfb5bedb83210007c06c.tar.bz2
aports-82b9c6a93fa49a2581dcdfb5bedb83210007c06c.tar.xz
testing/sxhkd: new aport
https://github.com/baskerville/sxhkd Simple X hotkey daemon
Diffstat (limited to 'testing/sxhkd')
-rw-r--r--testing/sxhkd/APKBUILD47
1 files changed, 47 insertions, 0 deletions
diff --git a/testing/sxhkd/APKBUILD b/testing/sxhkd/APKBUILD
new file mode 100644
index 0000000000..5055f5d68d
--- /dev/null
+++ b/testing/sxhkd/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: Olivier Mauras <olivier@mauras.ch>
+# Maintainer:
+pkgname=sxhkd
+pkgver=0.5.5
+pkgrel=0
+pkgdesc="Simple X hotkey daemon"
+url="https://github.com/baskerville/sxhkd"
+arch="all"
+license="bsd"
+depends=""
+depends_dev="xcb-util-keysyms-dev libxcb-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="https://github.com/baskerville/sxhkd/archive/$pkgver.tar.gz"
+
+_builddir=$srcdir/$pkgname-$pkgver
+prepare() {
+ # Apply patches
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+
+ # Fix $PREFIX
+ cd "$_builddir"
+ sed -i 's#^PREFIX.*#PREFIX ?= /usr#' Makefile
+}
+
+build() {
+ cd "$_builddir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ # Copy examples
+ mkdir "$pkgdir"/usr/share/$pkgname
+ cp -r examples "$pkgdir"/usr/share/$pkgname
+}
+
+md5sums="e04b8d7173059bce156bec6d8cd4297d 0.5.5.tar.gz"
+sha256sums="e6699f77564e34a890d27f6c251e1ed29b04f5177e48290e7f02948497f04313 0.5.5.tar.gz"
+sha512sums="a0ea812e4cbd63330768349045547f330cdaeec7edc3270af7e7acc4b025f7aa1d2550214db0aef9621ba619e82ee9459ee76b050cc23f780f67ed0f26e9550b 0.5.5.tar.gz"