aboutsummaryrefslogtreecommitdiffstats
path: root/testing/sylpheed-imap-notify
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2019-04-16 15:22:52 +0200
committerHenrik Riomar <henrik.riomar@gmail.com>2019-04-17 09:31:58 +0200
commitafa4f8230708aa0dc5a9d42d3ff012a30c47a2ff (patch)
tree9ad5cd9ef149deea0d3735c37bb0a4b3f943e881 /testing/sylpheed-imap-notify
parent5f61e0e106315c69b9cec8e394286e8cf98c99e2 (diff)
downloadaports-afa4f8230708aa0dc5a9d42d3ff012a30c47a2ff.tar.bz2
aports-afa4f8230708aa0dc5a9d42d3ff012a30c47a2ff.tar.xz
testing/sylpheed-imap-notify: new aport
Diffstat (limited to 'testing/sylpheed-imap-notify')
-rw-r--r--testing/sylpheed-imap-notify/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/sylpheed-imap-notify/APKBUILD b/testing/sylpheed-imap-notify/APKBUILD
new file mode 100644
index 0000000000..df87749c13
--- /dev/null
+++ b/testing/sylpheed-imap-notify/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer:
+pkgname=sylpheed-imap-notify
+pkgver=1.1.0
+pkgrel=0
+pkgdesc="An IMAP NOTIFY and IDLE plugin for the Sylpheed mail client."
+url="https://github.com/clehner/sylpheed-imap-notify"
+arch="all"
+license="GPL-3.0-or-later"
+depends="sylpheed"
+makedepends="sylpheed-dev gtk+-dev"
+options="!check"
+source="$pkgname-$pkgver.tar.gz::https://github.com/clehner/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make PREFIX=/usr SYLPHEED_DIR=/usr/include/sylpheed/sylph
+}
+
+package() {
+ cd "$builddir"
+ install -d -m0755 "$pkgdir"/usr/lib/sylpheed/plugins
+ install -m0644 imap_notify.so "$pkgdir"/usr/lib/sylpheed/plugins
+}
+
+sha512sums="8763bf271f2908c02112ae6f737f0435091d7f5f0b336cb60be6e655cc678c82cadde0d3d4fb595a673189b6b4444e65a8f753ff91fe5522423e20ec6e4ec339 sylpheed-imap-notify-1.1.0.tar.gz"